HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to replicate a new SNMP string

 
Steve Kadish
Trusted Contributor

Unable to replicate a new SNMP string

Hi all,

I am trying to change the SNMP strings on my servers to new, long, complex passphrases. I want to use the "Replicate Agent Settings" function of SIM, but I'm running into a snag.

Every time I change the SNMP strings on a server, and try to use that server as a replication target, "HP Foundation Agent" is no longer listed on the "Step 3: Choose Source Configuration Settings" screen. (See the attached bitmap.) Therefore I can't choose the SNMP strings as a replication option. I've seen this consistently on three different servers.

Is this a bug? Does anyone have an explanation for it?

I would use the "Configure and Repair Agents" function, but that in fact will add a new community string, not change the existing one. You also cannot specify the READ-CREATE string using that function.

Thanks,
- Steve


3 REPLIES
Albert Austin
Esteemed Contributor

Re: Unable to replicate a new SNMP string

Hi,
Is the Foundation Agent link available via the SMH on those servers?
Steve Kadish
Trusted Contributor

Re: Unable to replicate a new SNMP string

Yes, it does. Nothing appears wrong on the SMH. I should also add that I changed both the Global and System Protocol Settings to include the new SNMP strings.

Thanks,
- Steve
Steve Kadish
Trusted Contributor

Re: Unable to replicate a new SNMP string

Well, after much tedious experimentation, I've solved this mystery. It seems that Systems Insight Manager doesn't support the character '&' in an SNMP string. It's supported by Windows, but it breaks the "Replicate Agent Settings" function. As soon as I replaced it with another character, everything worked again.

I also have the '@' and '!' characters in strings but they don't seem to bother it!

- Steve