Server Management - Systems Insight Manager
Showing results for 
Search instead for 
Did you mean: 

Unable to run large task in SIM

Go to solution
Marvin Gee
Occasional Visitor

Unable to run large task in SIM


I'm looking for assistance in HP SIM v5.0 with SP4 on a peculiar problem when a task is run against hundreds of targeted managed systems.

I have over 330+ managed HP Proliant servers discovered in HP SIM. All these systems have iLO integrated into SIM as management processors.

I've created a small XML script using the RIBCL to toggle a function in the managed processor's iLO. I've tested this script on a half dozen managed servers, one at a time, and know it works because I see the task completed in SIM, the Task Results showed successful completion with no syntax errors and I connect into the managed server's iLO and see the feature automatically enabled as designed in the script.

The problem is when I try to push this scripted automation out to the remaining 330+ managed servers all together the task runs on and on, never completing the job. The task instance status continously shows "Running: 0%". One time I had this task run 12 hours overnight and the next morning it was still running without ever finishing it. And I can't stop or kill it - I have to log off and stop the HP SIM services in order to kill the job.

I've created a custom command that looks like this:

C:\folder\folder2\CPQLOCFG.EXE -f C:\folder\folder2\script.xml

I then run this command either against a custom created list with all 330 servers or against all management processors type list. No matter with targeted systems list I use the task just seems to hang not doing anything.

As I said this custom command runs fine when I run it against one managed system at a time but not against hundreds of managed systems at once.

I do have an alternative solution to push out this change to all my managed servers but it'll be more laborious and require multiple servers to accomplish this instead of just one CMS platform and one script if this had worked.

Any ideas?

Rob Buxton
Honored Contributor

Re: Unable to run large task in SIM

There is a bug in HPSIM sp4 where jobs do not complete.
It was fixed in SP5.
It showed up here where we geneerated a number of small jobs using the same script, some would complete others would show 0% complete and never finish.
Marvin Gee
Occasional Visitor

Re: Unable to run large task in SIM

Thanks to Rob Buxton's reply. Issue resolved by updating to SP5.