Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to subscribe to WBEM events.

Unable to subscribe to WBEM events.

I am having problems getting one of my servers recognized in HP SIM. The server is running HPUX 11.31. When I try to subscribe to WBEM events in SIM it returns the error “FAILED to create indication subscription.”

I have logged onto the server and ran the command “cimprovider –l –s” and this only returns a third of the modules that I would expect to see. See below:

cimprovider -l –s

MODULE STATUS
OperatingSystemModule OK
ComputerSystemModule OK
ProcessModule OK
IPProviderModule OK
DNSProviderModule OK
NTPProviderModule OK
NISProviderModule OK
SDProviderModule OK
IOTreeModule OK

I then ran the command “cimsub –lh” and this returned nothing, whereas on the other configured servers it returns the correct information.

When I run “ps –ef | grep –i cim” it only returns the following processes:

cimsrvr 24020 24019 0 09:23:30 ? 0:00 cimservermain --executor-socket 4
root 24019 1 0 09:23:30 ? 0:00 /opt/wbem/lbin/cimserver
root 23940 1 0 09:23:17 ? 0:00 /opt/wbem/lbin/cimserverd


I have tried removing WBEMsvcs but to no avail.

Thanks in advance.

 

 

P.S. this thread has been moved from Insight Remote Support > general to ITRC HP Systems Insight Manager Forum - HP Forums moderator

5 REPLIES
Olivier Masse
Honored Contributor

Re: Unable to subscribe to WBEM events.

From my experience, when you start having trouble with the CIM repository you're better off opening a support call. I've had two servers which had their WBEM services so screwed up, I didn't find any swinstall/swuninstall combination that resolved the issue.

You can use "evweb subscribe -b external -L" to list current subscriptions. Encouraging WEBES to subscribe can be tricky but SIM is usually straightforward. If you don't see any SIM subscriptions, ensure that your WBEM credentials are set correctly. Using root is a no brainer but not recommended, if using a dummy account you need to run a few cimauth commands to authorize it on your server.

Olivier.

Re: Unable to subscribe to WBEM events.

Thanks Olivier. "evweb subscribe -b external -L" does not list any subscriptions. I will open a support call.
Paul Kurtz
Valued Contributor

Re: Unable to subscribe to WBEM events.

are you using root to sign into system? if not you want to check cimconfig -l -p and make sure enableSubscriptionsForNonprivilegedUsers is true. Also sometimes removing the system from HP SIM and then discovering it again with good creds works.

Re: Unable to subscribe to WBEM events.

Paul - Yes I am using root priviledges. I have also tried removing from SIM and rediscovering but to no avail.
Rob Buxton
Honored Contributor

Re: Unable to subscribe to WBEM events.

I had similar fun with with ESXi. I also bounced the host server, really just to ensure all of the CIM providers got restarted. That fixed some wbem connectivity issues.