HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

VC Agent is not working on W2k3 machines

 
SOLVED
Go to solution
Rnollen
Occasional Advisor

VC Agent is not working on W2k3 machines

I am currently busy of implementing a HP Sim environment in our organisation with both W2k and W2k3 Servers as clients.

But while I am configuring the servers, I have problems with setting up the VC Agent. The VC Repository Service is running on my HP Sim Server.

The VC Agent is not working on most of the W2k3 Servers and unfortunately the VC Agent is also responsible that my Management Homepage is also not working good. The problems that I have is: System Model Unknown, Processor Tab is not filled in correcly and I get an time out when opening the Management Homepage.

I have searched this forum and it was said to check the settings of the SMTP service, but I don't see any error's there. I have also checked the settings with a working server. If I stop the VC agent service, the Management Hompepage is working like a charm and all the settings are correct???

I am using PSP 751A and some of the clients VC agent is upgraded from different older versions.

Does someone has got an Idea what I can check in order to get it fixed. I have also tried to reinstall everything, but with the same result On the W2k servers and one W2k3 server, the VC agent is working perfectly.
7 REPLIES
James Kennedy_4
Trusted Contributor

Re: VC Agent is not working on W2k3 machines

make sure SNMP allows localhost as well as the IP for the SIM server running VC Repository. Should fix your problem.
Rich Purvis
Honored Contributor
Solution

Re: VC Agent is not working on W2k3 machines

Anytime you get System Model Unknown - either your SNMP agents are not running and/or you have an SNMP configuration problem. The VC Agent also gets its data from SNMP so it is possible that this is the cause of your problems. You may want to check and make sure SNMP is actually running as I think the default for W2k3 is to not install it.

If you actually stop the VCA and all your data appears in the SMH, including the System Model - then most likely you have a configuration issue with VCA. The VCA will immediately try to connect and contact the configured Version Control Repository Manager when it starts up - if you do not have a system setup and running the VCRM then that will cause the timeout to occur. So you might check the VCA configuration to make sure it is pointing to a valid VCRM and is using valid credentials to access it.

-Rich
Why does my tivo keep recording Nickelodeon?
Rob Buxton
Honored Contributor

Re: VC Agent is not working on W2k3 machines

There's also a problem with the latest version of the management agents that a reboot seems to fix.
You get the timeout when accessing it and when you OK that screen you get most detauils from the SMH but not all, I found space used was missing among other things.
At the same time the VCA doesn't work.

As previous posters have mentioned, the server showing up as Unknown is an SNMP issue, which can be fixed without reboots.
Check community names and allowed hosts are set up correctly.
Rnollen
Occasional Advisor

Re: VC Agent is not working on W2k3 machines

@All
The strange thing is, if i send a SNMP test trap, it is working. The SMNP service is also running. In the SMNP service, the localhost and the name of my SIM server is specified.

But if I stop the Version control Agent Service, then the system Model is known and the management homepage is working like a charm? Is it then still a SMNP issue??

I have also tried to reboot some of the servers without succes.

On the client's I cannot edit the VCA Agent settings, on opening it immediately gives an error.
frank vandebergh
Frequent Advisor

Re: VC Agent is not working on W2k3 machines

It's a problem with your VC Agent Settings. Which error message do you get when you view these settings ?
Is there a firewall enabled on the VC Repository manager ?
G Edwards
Advisor

Re: VC Agent is not working on W2k3 machines

Note that there are two different SNMP communication paths.

Firstly, between HP SIM and the agents on the target machine. If you can send test traps then this is probably set up correctly. Make sure you have the HP SIM server listed in the "Accept SNMP packets from these hosts" box or set the "Accept any SNMP packets from any host" option.

Secondly, the agents use SNMP to talk to each other and the SMH. You need a READ_WRITE or READ_CREATE community which has a trap destination of "localhost". Also, you need to have "localhost" in the "Accept SNMP packets from these hosts" box or set the "Accept any SNMP packets from any host" option. The "Configure or Repair agents" task should set all this up for you.

To change these settings got to: settings->snmp configuration->Security and settings ->snmp configuration->Traps pages, on the SMH

Cheers,

Gary
Rnollen
Occasional Advisor

Re: VC Agent is not working on W2k3 machines

Thanx Mates..

It was a problem with the SNMP settings. If I altered the SNMP settings through the management console, then everything was working.

There was a strange community string there (looked like a guid number?) who was causing that the VCA agent was not responding. After deleting this String the VCA agent was working.
The Information of the SNMP settings in the Management Homepage was sometimes also different then the information in the SNMP Service. The settings for SNMP service of windows are pushed through a GPO.

So now I have to alter something I think the Global Settings for SNMP of SIM, going to look into that...