Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

VC Agent not Configured?

remora
Advisor

VC Agent not Configured?

Hi All,

I have built a new box 03 Srv, and installed SIM 5 on it. I have upgraded all the psp's on my managed servers and manually added them to SIM. I have created a certificate on the CMS box and added it on the managed servers when logging into the system management page.

However I cannot configure the VCA, when I click on Hp Version control agent on the system management page, and change agent settings, I enter my cms box and get "The specified repository, #########, is invalid or not reachable."

I have snmp setup and configured on the CMS box and the managed server. If I point the managed server to another CMS server it works fine!!

Any help much appreciated.

Cheers
10 REPLIES
Aest
Honored Contributor

Re: VC Agent not Configured?

To start with,

try pinging, name resolution and access the shares.

Any Firewall?

The account used by the VCA needs to be member of a local windows group which is at least member of the SMH's Operator group.

HTH

Cheers!
There is nothing impossibe!
remora
Advisor

Re: VC Agent not Configured?

Hi Aest,

Yes I can ping the CMS box from the managed server and vice versa, I have created a domain account that is a local admin on the CMS box and has full rights in SIM.

Cheers
remora
Advisor

Re: VC Agent not Configured?

Does anyone have any other suggestions? Still stuck on this?
James Dryfoos_1
Occasional Contributor

Re: VC Agent not Configured?

Presuming the VC Repository Server is setup on your SIM CMS, make sure your agents can make a TCP connection to your VC Repository server on TCP port 2301. You can try telnet to 2301 to see if can connect.

Good luck.

-- Cheers
Rob Buxton
Honored Contributor

Re: VC Agent not Configured?

By clicking the link to the server hosting the VCRM and going to Tools & Links you should see a link to the VCRM itself.
Is access to that okay? has it been configured with a repository?

From the VCA side I've had more luck using a local account, given local admin rights on the VCRM Server.

Also the Trust relationship needs to be okay, if there's a Trust Issue and you use trust by certificate you might want to delete the existing cert for the CMS Server and use the Get Certificate to reimport one.
Once done, rerun the Software Polling task.
remora
Advisor

Re: VC Agent not Configured?

Thanks Rob, still battling away though.

On my Sys Mng Home Page, under Version Control, I hve a lovely big green tick next to "HP Version Control Repository Manager" and a big blue question mark next to "HP Version Control Agent"

However when I go to Change agent settings" on the VCA home page, I get the error "The specified repository, Server1, is invalid or not reachable."

Does the repository need to be a share, or a hidden share? What is the VCA looking for that it can't find?

Thanks in advance.
Steve Weeks_1
Frequent Advisor

Re: VC Agent not Configured?

personally, i'd guess at this being a Name resolution issue.

We have this in a Multi Domain environment a few times.

i therefore use the

server.msft.com name or the IP address.

Usually works ok then.
Daniel Leblanc
Honored Contributor

Re: VC Agent not Configured?

I had 2 cases like that in the past..

1#__The first was resolve by doing VCRM to the lastest version ,so did the same thing to the VCA. Problem was resolve.

2#__The second was resolve by change the HOSTNAME to the IP address,Resolve.

Tri it?Wont hurt.

HAve a nice day

Dan
Daniel Leblanc
Honored Contributor

Re: VC Agent not Configured?

I had 2 cases like that in the past..

1#__The first was resolve by doing VCRM to the lastest version ,so did the same thing to the VCA. Problem was resolve.

2#__The second was resolve by change the HOSTNAME to the IP address for the VCRM in the VCA,Resolve.

Tri it?Wont hurt.

HAve a nice day

Dan
NateG
Occasional Visitor

Re: VC Agent not Configured?

I'm not sure if this is the correct way to do it, but here are the steps I followed:

1. reinstall VCRM over existing version--everything looked ok

2. repository was in c:\Repository. I went ahead and shared the folder with default settings.. because my previous server was shared. I think it's supposed to be done automatically, maybe in step #3.

3. go into SIM and run Options -> Identify Systems and choose your repository manager. After it runs, SIM will find the repository manager on your system, and then you can configure it.