Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

VCA Missing Inventory

Ryan Kather
Occasional Visitor

VCA Missing Inventory

I have about 24 servers running PSP 7.90 (and one 7.91) on SUSE Linux Enterprise Server 9 SP3 (x86). Of these about half work fine with Insight Manager and report their complete PSP inventory. The other half only show the VCA agent version.

The VCA log indicates; vca-task The ProLiant Insight Agents are not installed or running, so inventory data is not available.

Only I've verified that the Insight agents on the server are running... HPASM is started HPSHM etc... is there a specific process I'm missing? What would cause this issue?

Thanks for any help,
Ryan
7 REPLIES
Rich Purvis
Honored Contributor

Re: VCA Missing Inventory

If you go to one of the systems that is exhibiting the problem. What does the System Management Homepage look like? Browse to port Http-2301 or https-2381 and look to see if any data is displayed in SMH. There used to be an installed software list in the SMH - does that page show up? This would be a good indicator of whether or not the agents are running and providing data properly.

-Rich
Why does my tivo keep recording Nickelodeon?
Ryan Kather
Occasional Visitor

Re: VCA Missing Inventory

I thought I replied to you, but apparently I didn't confirm. I can login to https://server:2381 and the SMH comes up fine. Everything looks green. If I head into the Version Control Agent screen Software Status is Green but the only installed software listed is the VCA.

The VCA log says that "The Proliant Insight Agents are not Installed or Running, so inventory data is not available.".

I've attached a zip with screenshots.

Thanks for the help.
Jose Vicente Mondejar
Occasional Visitor

Re: VCA Missing Inventory

Have you solved this problem? I'm having the same message in the VCA logs

Thank you
Predator
Trusted Contributor

Re: VCA Missing Inventory

Hi,

If the problem is not solved then try configuring the snmp and restart VCA agent.
keep in mind, hpasm is running.

Thanks
Predator
Jose Vicente Mondejar
Occasional Visitor

Re: VCA Missing Inventory

Problem solved,
thank you
Hardware Support
Occasional Visitor

Re: VCA Missing Inventory

Hi,

Can you give me a short description, what the cause was and what you've done?

Thanks, Andre
Jose Vicente Mondejar
Occasional Visitor

Re: VCA Missing Inventory

There was a problem in the script to run the snmp daemon.
Looking in the logs I found that it had not the right parameters. I corrected it and now that works.

File /etc/init.d/snmpd had the following line :
OPTIONS="-Ls 5 d -Lf /dev/null -p /var/run/snmpd.pid -a"

And I removed the "d":
OPTIONS="-Ls 5 -Lf /dev/null -p /var/run/snmpd.pid -a"