HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

VCA responds from SMH, but not directly

 
MC Murphy
Frequent Advisor

VCA responds from SMH, but not directly

This is SIM 6.0, all Proliant Windows servers. On my SIM Server screens, on 30 of 33 servers, "Software Status" shows the "i" communication error icon. I press it and get the "http error communicating" screen. The other 3 have valid status, and the VCA opens. But on all those 30 with the error, the "System Management Homepage" link under More Information opens the SMH on the server, and from there I can open and use the VCA, no problems. I've examined the three that work, others that don't - certificates, trusted mgmt server, etc - and can't see what's different.
6 REPLIES
Rob Buxton
Honored Contributor

Re: VCA responds from SMH, but not directly

Try running the SW Polling task for those servers, otherwise rerun the ID Task and then the SW task.
Tim LeBlanc
Occasional Visitor

Re: VCA responds from SMH, but not directly

I have been having the same exact problem. If I go under Tools & Link Tab for one of the affected server, and click the VCA link, it opens up fine, then if I perform a software status polling, the status shows up. I did that for all of my servers who were not giving a status thinking it might resolved the issue. The next day, 3/4 of them when back to the status of "i" communication error icon. I have since opened a ticket with HP support, but have yet to get a reply from them.
MC Murphy
Frequent Advisor

Re: VCA responds from SMH, but not directly

I ran the ID task, with mixed results, many servers said install WBEM and/or Insight Mgmt Agent; though those are current on all servers. I went on to the Software Polling task, then 21 of my 33 servers were showing a live software status instead of an I. I guess I'll see what's happening tomorrow. Thanks, and I'll be back.
MC Murphy
Frequent Advisor

Re: VCA responds from SMH, but not directly

Today I have the same 12 that give me the "i" communication error; 21 whose VCA opens successfuly from the SIM console. But today when I try SMH on the problems I get the message "A timeout occurred while loading data for the HP Sytem Management Homepage which may result in missing or incomplete information." I know this is the VCA's doing, because I OK this message, SMH opens but VCA is missing. I've read notes giving a variety of solutions to this timeout. It's my most frequent irritating issue with System Insight Manager, this timeout. I'm going around now to verify SNMP Service settings on the problem agents.
Rob Buxton
Honored Contributor

Re: VCA responds from SMH, but not directly

There is an issue with older versions of the VCA that hang.
That will give SMH time out issues and will stop the SW polling task from completing.
Check in:
C:\hp\hpsmh\data\cgi-bin\vcagent\cache
If there are only 4 xml files and one is 0 length then the VCA is hung.
Kill vcagent.exe then start the Version Control Agent (you can't stop the service)
Then browse to the VCA and it should repopulate okay. If the SW polling task is first to the VCA after a reboot it corrupts the cache.
MC Murphy
Frequent Advisor

Re: VCA responds from SMH, but not directly

All the servers' vcagent\cache folders had 5 to 8 non-zero size files, except one server whose vcagent\cache had no files; Until I started its SMH, then it created 4 files; none of them zero size; but still a Software Status communication failure. I try in SIM Configure \ Manage Communication with this server, it puts a warning on the Run Tools icon, then says "Secure Shell is not installed on this sytem". But VCA on this system tells me OpenSSH Services for HP SYtem Insight Manager V5.1p1-3 is installed, and V1005.4.0.0 is available as an update. I selected it and updated earlier this morning, it said successful, status 2 (restart needed). I restarted the server, it comes up with the same older version installed, newer version available; still non-communicating software status. The VCA log says cp004878.exe was downloaded and successfully installed. I search cp004878 in HP downloads and drivers, that identifies it as V1.5.4, August 2004. Is that really the newest OpenSSH for a Windows Server 2003 Proliant? This reply is rambling, but that's how I get with SIM; often feel I spend as much time dealing with quirks like this as I do getting useful information from it. But VCA is a top priority for me, keeping drivers and utils current is important like Windows update.

So, what's the newest OpenSSH? Where do I find it? Could it be causing the VCA non-communication, timeout errors?