Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

VCRM and SIM integration - VCRM broken

TrevorT
Occasional Advisor

VCRM and SIM integration - VCRM broken

I setup a 7.1 server maybe a year ago and got the software notifications more or less working.  after i had some issues I encded up blowing out my SIM install and reinstalling all the components.  Several months ago I updated it to 7.2.  About 2 weeks ago I updated it to 7.22.

 

I had been having issues with VCRM working, but had given up on it.  I know that some servers were reporting their software version info back in the original 7.1 install.

 

Anyway, I have all the latestest versions for SMH, VCRM, VCA, and SIM (7.2.2).  I'm running SIM and VCRM on same server, it's a VM on ESX 4.1.

 

I saw this post which talked about there being time out issues.  This sounded like a likely culprit, but the fix dind't work for me.  I tried several timout values.

http://h30499.www3.hp.com/t5/ITRC-HP-Systems-Insight-Manager/Attempting-to-populate-VCRM/td-p/4289766#.UnYHIHfKxPo.

 

My database for VCRM is almost 27 gigs.  My processors were pegged much of the time and I added a couple processors for a total of 4.  This helped the utilization, but VCRM still doesn't work in SIM.

 

To be clear, on individual machines I can configure the VCA to talk to the VCRM and they work just fine.  I can see what versions are available, and I cn update software on local machines via the VCA.

 

I've tried changing the trust on the SMH on the SIM server to 'trust all', but that doesn't help.  The error I always get when I go to options- > software/firmware -> version control repository is:

"Error retrieving repository. Ensure the Version Control Repository Manager (VCRM) is installed and running. Be sure a trust relationship is established with the repository device. Finally, the VCRM may not respond if it is in the process of updating its catalog. In this case simply try again later."

 

It may or may not be worth noting that I originally setup the VCRM to get updates for windows 7 on accident.  When I go into the VCRM via SHM and try to delete them the VCRM times out trying to get rid of them and I can't delete them.

 

How can I get SIM to use the VCRM?  It sees the VCRM, but it can't access it.

2 REPLIES
TrevorT
Occasional Advisor

Re: VCRM and SIM integration - VCRM broken

I got it to work.  To understand, this is some information from the other post I linked:
"By default SIM only waits 15 seconds to retrieve all the VCRM data which is very commonly not enough time

The fix is to edit globalsettings.props
http_request_timeout=15 change to 60"

 

I tried several different values, up to 270, and it still didn't work.  As a last resort I put in '600'.  But I did it for both "http_request_timeout" and ALSO for "VCRM_timeout".  Anyway, that worked.

 

The only thing I'm still curious about is how other people are dealing with HUGE VCRM database sizes.  I know 27 gigs is more that VCRM is designed to handle (efficiently).  How do other people deal with it to make it a managable size?

Andrew_Haak
Honored Contributor

Re: VCRM and SIM integration - VCRM broken

Hello TrevorT,

 

Why don't you install more than one VCRM. A virtual is enough. Just install System Management Homepage and then install the VCRM. I use a virtual for the older baselines/PSP's.

 

Kind regards,

 

Andrew

Kind regards,

Andrew