Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

VMM integration failed

Alexander A
Valued Contributor

VMM integration failed

Hi. I am trying to add PMP to three ESX servers, and that requires the VMM agent. The problem is I can't get public keys to work so I can't deploy the agent. I tried to solve that by manually installing the client. It worked, but I still cannot license the agent. The system indentification says this:
...
Running VM Identification
The system is a VMware ESX Host and has guests running on it
...
Running VM identification.
VMM Integration is not enabled, skipping VM Identification


Custom tools work and they use SSH, so I can't figure out why the deploy complains about public keys. But a the moment I just want the VMM agent to work so I can monitor CPU and memory. Any ideas?
4 REPLIES
Rob Buxton
Honored Contributor

Re: VMM integration failed

See this thread - it covers how you can manually get VMM integrated.
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1262716

Search the forum for VMM as this has been asked before.
Alexander A
Valued Contributor

Re: VMM integration failed

Thank you. I should probably have said that I have installed the VMM agent and run the importcert.sh. It has deployed the .ks-files to the correct directories and "mxagent -a -n -u -p " works fine and the hash in the keystore on the CMS looks like the DSA cert from the SSHD keystore. No problems there that I have found.

Custom tools also works, and custom tools use ssh. But a configure/repair, deploy VMM or a "register vmm" from the SIM console all complain about "public key" authentication.

Unless there's a bug here there must be something else I missed or a step that looked like it worked but didn't :/

Any more ideas? If you got it working, do you remember exactly what you did and in what order you did it?

The ESX servers are 3.0.2, sim is 5.2 sp2, VMM agent is the newest (don't remember the version atm).
Rob Buxton
Honored Contributor

Re: VMM integration failed

Not at work at the moment so can't verify things too much.
I do know I don't rely on SSH at all for the connectivity.
Once I had the VMM Agent installed and the certs loaded then I believe registration should work.
You should see the VMM as an enabled service in the ESX Firewall - so check that - esxcfg-firewall --query will list everything.
Alexander A
Valued Contributor

Re: VMM integration failed

Hi. Registration works but only with mxagent utility - not from the console.

I finally gave up and opened all ports the HP agents were listening on + all ports mentioned in the Virtualization Management Software User Guide. Still the same error :(

SSH public key authentication failed.
Target system ...esx01.dom might not be configured.
Please run mxagentconfig -a from command line window or Configure->Configure or Repair Agents from graphical user interface to configure the target system.
EXCEPTION CLASS :
com.hp.mx.dtf.sshClient.MxSshAuthenticationFailedException
EXCEPTION :
SSH public key authentication failed.Target system might not be configured.Please run mxagentconfig -a from command line window or Configure->Configure or Repair Agents from graphical user interface to configure the target system.