Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

VMWare 3.x Partially Updating SIM Console

SOLVED
Go to solution

VMWare 3.x Partially Updating SIM Console

With Rob's help the other day, I got my VMWare 3.x host communicating with the SIM Console and Homepage by reconfiguring snmp correctly.

I tested the agent by unplugging one of the redundant power supplies from the server. The VMWare host's homepage reported the problem, but the SIM Console did not. The Console does log snmp traps from the vmhost though. Any thoughts on whether there are still problems with my snmp settings or if the agent configuration is the problem?
4 REPLIES
Rob Buxton
Honored Contributor

Re: VMWare 3.x Partially Updating SIM Console

If you go to the Home Page on the VM Host Server and go to Settings-> SNM Configuration there's an SNMP Trap Send button at the bottom.

That should send a trap to your HPSIM Server.
If you select the ES link for the VM Host Server you should see a Generic Trap with a Major status listed.
If you don't, then there's still an issue with the trap destination setting in snmp.

I have seen some comments about some aspects of the trap send mechanism not working on ESX Hosts for some items, alas I can't recall which particular sub-agent was involved.

Re: VMWare 3.x Partially Updating SIM Console

Rob,
The Send Trap does work and a "Generic trap (11003)" record is logged in the SIM Console within seconds of being sent from the vmware host server's SMH.

The troubling part is that when I unplugged one of the redundant power supplies on the esx vmhost, it showed up on the SMHomepage of the esx box, but not in SIM Console. I'm thinking of uninstalling and re-installing the installvm770.sh.

Are you aware of any issues if I re-install the agent?

Thanks,
Serge
Rob Buxton
Honored Contributor
Solution

Re: VMWare 3.x Partially Updating SIM Console

I don't think uninstalling / reinstalling will fix this.
At least you know the mechanism is right and the agent to snmp connection works.
Try looking through the forums, I have seen something similar reported. It may have been regarding PS's not being correctly reported in ESX.

The other thing you may want to dig down and check is the status of the sub-agents.
There are a few and they can be started or not, it's contained in one of the config files but I cannot recall which.

Re: VMWare 3.x Partially Updating SIM Console

Rob,
Thanks very much for your help.

I ran "service hpasm status" as root and noticed that some of the storage agents were not running.

I then ran "/etc/init.d/hpasm reconfigure" and noticed that some of the changes I had made yesterday to the /snmp/snmpd.conf file hadn't been saved, so I made appropriate changes where needed. When I re-ran the hpasm status, all storage agents were running and all snmp settings looked good.

I opened my SIM Console and saw the "Power Supply Failed" event from my esx host.

All is good. Thanks, again.
Serge