Server Management - Systems Insight Manager
Showing results for 
Search instead for 
Did you mean: 

VMware ESX: unable to get host info

Marco MM

VMware ESX: unable to get host info

- On one ESX 3.01 I installed HP Management Agents for VMware 3.x 7.7.0.
- I have also a central HP SIM 5.1 (mgmt_IP).

- Edited on the ESX the file /etc/snmp/snmpd.conf in this way:
rocommunity myreadcomm
rocommunity myreadcomm mgmt_IP
trapsink public

- mgmp_IP is resolved correctly
- from mgmt_IP I can do an snmpquery using commmunity "myreadcom" (with an snmp-query software to test results)
- I can remotely connect to HP Management Console on ESX and see the homepage and all features (I can telnet to port 2381 on ESX - so firewall port on ESX is open)
- HP System management Homepage on ESX is configured, in security, "trust mode" to "trust all"
- mgmt_IP receive trap from ESX (for instance when I restart the snmp service on the ESX an entry "cold start" in HPSIM is generated)
- I configured HP SIM to ping using TCP on an particular TCP port (xxxx) and it works (so firewall port on ESX is open)

All seems to work fine but when I try to discover my ESX from HP SIM (to gather ESX dataand import it into the HPSIM infrastructure) it fails with this error:
"Data collection was skipped for this system because it is suspended or inaccessible.
Root Cause: The target system has been suspended or somehow become inaccessible.
Corrective Action: Check system status and reset (if appropriate) the following System Page: Suspend/Resume Monitoring."

Can someone help me?

Thanks in advance.
Rob Buxton
Honored Contributor

Re: VMware ESX: unable to get host info

Check what protocols have been discovered, click on server name look under the Product Description.
You should see items like:
HTTP:0.0, SMH:2.0, SNMP:1.0, SSH:SSH-2.0-OpenSSH_3.6.1p2
If you've made changes to snmp, try rerunning an identification task.

In my snmpd.conf file, I use the FQDN of the vmhost server. Not sure if that would make a difference.

Test browsing to the SMH from the HPSIM server.
Marco MM

Re: VMware ESX: unable to get host info

Under the Product Description I can only see "Unmanaged"

Rerunning an identification task do not solve the problem

Not sure what do you mean with "In my snmpd.conf file, I use the FQDN of the vmhost server." snmpd.conf is on the vmhost so maybe you add in it the HPSIM FQDN.

SMH from the HPSIM server works well.
Marco MM

Re: VMware ESX: unable to get host info

I have news, not really good news:
magically, during the week-end, one server (another continue to not work) has been visible for HP SIM for sometimes in fact HP SIM could import it and collect all data.
I saw it in the morning and in the same time I tried to connect to SMH of the ESX...without success! the SMH stopped working!! I stopped snmpd, hpasm, delete the RW community line into snmpd.conf, start snmpd and hpasm and try to collect ESX data from SIM: IT WORKS!!! and now it continues to work...but don't know why! In fact I replicated the same settings (settings I tried many time before but without success...what is changed...maybe the weather!!) on the other ESX and it continue to not work.

I lost any hope now Really frustrated for HP agents for VMware and SIM product!