Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Version Control Repository Manager not available in System Management Homepage

zwaagp
Occasional Visitor

Version Control Repository Manager not available in System Management Homepage

I have installed HP Systems Insight Manager 4.2 SP2 on Windows Server 2003. After that I installed the newest release of Version Control Repository Manager, 2.1.3.740, on the same server.
The problem is that the VCRM link is not available on the System Management Homepage (2.1.3.132) so I can't configure and use it with SIM.

I have tried the things you do in such case, like reinstalling, reboots, restart involved services and so on, but the problem still exists.

What can I do to resolve this?
2 REPLIES
Ananthak23
Trusted Contributor

Re: Version Control Repository Manager not available in System Management Homepage

Make sure that VCRM service is running. Try browsing to https://hostname:2381/vcrepository
If it says "The application is not available." then VCRM service might be stopped. Checkout for any errors from "cpqsrhmo" in the NT eventlog.

-Anantha
zwaagp
Occasional Visitor

Re: Version Control Repository Manager not available in System Management Homepage

I solved the problem.

I found that there should be a vcrepository.xml file in C:\hp\hpsmh\webapp to show the link on the SMH.
But after the installation of the VCRM, which was succesfull according to summary showed after installation, the file was not created in the directory. And the reason why? Because only the SYSTEM account was able to write in that directory.
I think that the installation of SMH did modify the security rights of the folders so the xml file could not be copied to that directory.
After modifying the security rights and rerunning the setup of VCRM, the xml file was correctly placed in that directory and as a result the VCRM link showed up in the SMH.

But, what I want to know, what is the reason for the modified acces rights of that folder? And why does the VCRM tell me that the installation was succesful while it wasn't?