Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Machines not recognized

 
Oliver Berry
Occasional Contributor

Virtual Machines not recognized

I would like to get my VMware ESX windows VMs to be shown as such in SIM5 SP5.

They currently show as system type unknown, and Product Model is blank.

I dont need VMM as we have other tools for managing VMs but would lke SIM to show Virtual hardware correctly.

If anyone know how to do this - id love to know.

Thanks

Thanks
17 REPLIES
Rob Buxton
Honored Contributor

Re: Virtual Machines not recognized

Use WBEM, it will need to be enabled globally in HPSIM, if you don't want global WBEM leave the credentials blank, then you'll need to override these with the server specific wbem credentials.
This will at least identify it has a Virtual machine.
To associate it with a host etc. inside HPSIM you'll need VMM.
Gerald LaVallee
Frequent Advisor

Re: Virtual Machines not recognized

I have similar problem... what account do I use for WBEM Settings? Under the Product Description most servers don't have the WBEM Protocol; what am I missing?
What ever it takes!
Rob Buxton
Honored Contributor

Re: Virtual Machines not recognized

depends on the OS, Windows usually has the WMI installed by default. I use Domain credentials that have full access. You could use local credentials if you want.
Gerald LaVallee
Frequent Advisor

Re: Virtual Machines not recognized

SO then the next step is to Register the VM Host using "Configure / Virtual Machine Host Registration"? When I do that, I get an ShhAuthentication failed. OpenSsh is configured to use the service account installed with... I'm back to square one in that it is very difficult to install and configure OSSH!
What ever it takes!
Wayne from Fla
Occasional Visitor

Re: Virtual Machines not recognized

Here is the real problem that I got from an HP SIM expert: The problem has to do with Microsofts implimentation of WMI. On the SIM server you should have a service called the Pegasus WMI Mapper. This service does the translation for SIM so it can ID servers. It has a problem with VM instances. If you cycle this service, select all of your VM instances, and then select options --> Identify systems it will start to recognize your VM instances. Unfortunately the information will dissapear again when SIM polls for info. I was hoping they would have a fix by now, but I haven't found one.
Dave Behler
Frequent Advisor

Re: Virtual Machines not recognized

Likewise, I can get my VM's to report into SIM, but the next day they are back to unknown. I recycle the wmi mapper and rediscover the vm's and all is fine for another day.

I did see several other posts with people "losing" their VM's and some workarounds to keep them from dropping out. Unfortunately, none of the workarounds seem to work for me. Someone please help!
Greg Bates
Advisor

Re: Virtual Machines not recognized

I am having the same issue. As a workaround, I set up a scheduled server task to restart the WMI service right before the daily Identifiication task that runs in SIM. This has solved the issue for now.
Kimik
Frequent Advisor

Re: Virtual Machines not recognized

Hi Oliver,

I have this problem as well. All VMs are unknown system type. I would at least expect the OS name to be discovered. I'll have a test with WBEM and see how it goes, but it's a shame to need to fiddle with VMs .. longer term maybe VMM helps but really with Virtual Center we dont need the VMM anyway.


kim
There's no present like time
Dave Behler
Frequent Advisor

Re: Virtual Machines not recognized

Kim, I've found that you must use an admin account to successfully query against wbem/wmi via HPSIM. I'm not sure why as I've found several HP documents, white papers and best practices surrounding wmi & vm's that clearly state that no special priviledges are needed.

I'm not sure why this is, but if I don't use an account (whether it is a domain or local server account) that has admin access I get "Unknown WBEM error".

If someone could shed some light on this that would be great.
dospavlos
Frequent Advisor

Re: Virtual Machines not recognized

I've only gotten wmi/wbem to work with a user that has local admin priviledges on the target systems. I found an HP doc that states a user with limited rights should be used and a few wmi security changes are required. My case with HP on this has been escalated to the next level of support. I will post any updates.
Dave Behler
Frequent Advisor

Re: Virtual Machines not recognized

I think I found the document that allows non-admin accounts access via wbem.

http://h18013.www1.hp.com/products/servers/management/hpsim/infolibrary.html#b6

From that link select advanced mgmt features and then read the understanding hp sim security. Read the Configure managed systems section on page #10 and it outlines what needs to be done on each system to allow non-admin access into wbem.

I have not tried this as I just stumbled across it.
dospavlos
Frequent Advisor

Re: Virtual Machines not recognized

David, I got this working and that was the doc I used. The doc doesn't state one thing you need to do which I found out from the HP engineer - the security for the user you add in wmi must have it's rights applied to subnamespaces. I also had to add my user to the local 'Distributed COM Users' group. HP Engineer said he got his working without that step. If anyone else gets this working please post your fix. Here's what I did:

ON TARGET SERVER:
Computer Management\WMI Control:
Highlight WMI Control, click Properties
Security/Root/Security/Add
Add domain user and enable 'Enable
Account' & 'Remote Enable'
Advanced, highlight account, Edit
Apply onto: Namespace and subnamespaces

Local Users and Groups/Groups:
Add domain user to 'Distributed COM Users'

CMS CONSOLE:
Protocol Settings/Global Protocol Settings:
Check box for 'Enable WBEM'
Specify domain user & password (domain\user)
Kimik
Frequent Advisor

Re: Virtual Machines not recognized

Thanks for all the support folks. I've tried as a first pass adding a local admin user to the WBEM global properties. What has to happen for the OS discovery to occur? I've tried running the Bi-Weekly data collection tasks, Daily Device Identification Task but still the OS type for these VMs isn't populating.

Although as I type I wonder maybe it's the Sofware Version Status Polling. Will run and post back results...
There's no present like time
Kimik
Frequent Advisor

Re: Virtual Machines not recognized

Okay - I ran the software discovery, and the only VM it's identified properly as hardware type "VMWARE Virtual Platform" and running Microsoft Windows OS, is the HPSIM virtual machine itself!

Close but not close enough.
There's no present like time

Re: Virtual Machines not recognized

Restarting the mapper and running a idenity job worked for me, thanks

I am seeing another bug. Its adding a one to the guests. So say I have a virtual apse9106 I see apse9106 and apse91061. Not sure what to do about that. Its annoying
Kimik
Frequent Advisor

Re: Virtual Machines not recognized

Not sure how to do this. I've restarted the whole HPSIM server , and run the identification task, still not getting any more VM info...

:(
There's no present like time
Rob Buxton
Honored Contributor

Re: Virtual Machines not recognized

I've had a lot of fun recently with wbem, but I've now got it back to a stable state (I hope).
I disabled WBEM globally and then stopped the HPSIM Service and then renamed the nodesecurity.xml file. Started the HPSIM Service and let it recreate the wbem file.
At this point I re-entered the HPSIM server for the wmi mapper proxy. I then enabled wbem globally but left the credentials blank.

I then entered server specific domain credentials for a number of VM Servers as well as the as the server that hosts CommandView for our EVA's. This also has a specific wbem credentials for the SMI-S collector.

I then redid some Identification tasks followed by data collections.

I've recently done a P2V migration and after deleting the old physical server and discovering the new one, adding the wbem credentials it was correctly identified.

We also use VMM, but I got the wbem working before the recent update to wbem came out.