Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Server Guests Not Being Discovered

Mark Blonde
Advisor

Virtual Server Guests Not Being Discovered

Hello,

I've just installed HPSIM 5 with SP5. When I did the discovery, our virtual guests (Microsoft Virtual Server)came in with wrong names, and sometimes were identified as hosts instead of as guests. I deleted them and then tried to rediscover them; unfortunately, I'm unable to re-discover them (although a couple appeared). I had deleted the hosts as well and they came back correctly. How would I be able to re-discover the guests? Note: we're not using VMM as of yet, all I want is that the guests appear as servers in SIM.

Thanks in advance.
Mark

If you don't have what you want, want what you have.
2 REPLIES
Rob Buxton
Honored Contributor

Re: Virtual Server Guests Not Being Discovered

Check your discovery filters, disable if they're set. Check they're in the discovery range, you should be able to manually add them.
The guests may be turning up as unknown and not being displayed.
To get any info about them if yoy don't have snmp installed will be to use wbem.
Check wbem is enabled and you either have global credentials or sever specific credentials set.
Mark Blonde
Advisor

Re: Virtual Server Guests Not Being Discovered

I verified all these items and I was still getting the same problem. What was funny, is that SIM always found one virtual guest but never more. What I realized is that, since we are using a template to create new virtual servers, every virtual has the same serial number which is identified in the *.vmc file. In the SIM 4.2 this didn't seem to matter; however, SIM 5 is only seeing one system based on the serial number and associates the various IP addresses of all the systems to this one system.

The solution is to change the serial number in the vmc files to a unique one which of course requires that the guest be restarted.

Cheers,
Mark
If you don't have what you want, want what you have.