Server Management - Systems Insight Manager
Showing results for 
Search instead for 
Did you mean: 

WBEM failures doing data collection.

Frequent Advisor

WBEM failures doing data collection.

Hi, I have seen threads on this in the past with no clear resolution.

Problem: Attempted data collection on a windows system(Some are VMs) yields this result - "An error occurred connecting to this system with the WBEM protocol. Check the system configuration."

It has worked before and my primary motivation was to get some of the VMs reporting proper data back(Changing from Unknown to Server) into SIM using the VM\SIM Guide.

SIM CMS server: Windows 2003 running SIM 5.4 database is on a seperate system running SQL.

Any help would be appreciated including where to look to get more info(log file?) on troubleshooting the error since it is pretty vague and unhelpful. Thanks!

Rob Buxton
Honored Contributor

Re: WBEM failures doing data collection.

You could try overriding the Global settings with system specific settings fo WBEM and see if that makes a difference.

Are you using AD or local account access? You should be able to use the format of domain\username in the WBEM config box.

I use WBEM here and the VM Servers are correctly discovered, although that may be a feature of VMM.
jim goodman
Trusted Contributor

Re: WBEM failures doing data collection.

In 5.0 VMs info is populated via WMI/WBEM protocol and in 4.2 VM identification was a function of the VMM if memory serves me correctly.

You can make sure you are authenticating by connecting via WMI by downloading Microsoft's WMI Tools and using the Obeject Browser to connect to the CIMv2 Hive.

- Jim
Frequent Advisor

Re: WBEM failures doing data collection.

Thanks guys, helpful tips so far.

I have tried adjusting to not using the global properties fro WBEM with no positive effect so far. Tried with both local and domain users.

I also loaded up the WMI Object Brower and was able to pull up CIMv2 on a failing machine from both my workstation and from the CMS server. I also tried WBEMTest as well to see if results would be different and they were not. I'll be calling a case in to HP shortly.

Does anyone know if the reason the error message was generated is logged at all? I can't find anything more descriptive. It would be nice to see if it was an access error or failure to read CIMv2 so at least I knew where to go next. I tried the mx logs already with no luck. It doesn't post a stderr at all.