Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

WBEM not working

 
Rene Nascimento
Frequent Advisor

WBEM not working

I can't get WBEM to install on my Windows 2003 servers. I'm running SIM 5.1 SP1 on Windows 2003. I have the OpenSSH service running on my SIM server and have the login and passwords set under Global Protocol Settings. Everytime I run Subscribe to WBEM events all my Windows 2003 servers fail with the same error -> FAILED to create indication subscription.
Only my SIM server has WBEM installed and functioning. What am I missing? The WMI service is running on all my Windows Servers.
6 REPLIES
David Claypool
Honored Contributor

Re: WBEM not working

I think you're confusing several different things. You don't install WBEM on Windows servers, they use a Microsoft variant called WMI. HP SIM speaks "pure WBEM" which is Common Information Model information from the CIMv2 namespace encoded in XML and transported over HTTPS. WMI however is transported over DCOM and has its own namespace. The WMI Mapper is used to translate back and forth between the 2 protocols and between the namespaces.

Subscribing to WBEM Indications events is currently only supported for Linux, HP-UX and SMI-S providers. There's nothing to subscribe to at this point on Windows. If you are working with ProLiant servers, SNMP and SNMP traps are used and not WBEM.
Rene Nascimento
Frequent Advisor

Re: WBEM not working

Thanks for the reply David. Before I upgraded to SIM 5.1 I was able to click Tools>System Information>Properties and view WBEM info on my Windows 2003 servers. Why isn't it working now?
Chez_1
Occasional Visitor

Re: WBEM not working

It usually helped at least on my setup to install the wmimapper.msi application on all servers.Check the SIM 5.1 setup directories for the wmimap folder or wmimapper.msi. If you cant find it check hp website.
Martin Smoral
Trusted Contributor

Re: WBEM not working

David,
I thought WBEM and the WMI Mapper were used to manage Proliant Servers running Windows behind a firewall when you do not want to open the SNMP ports on your firewall ?
martin
David Claypool
Honored Contributor

Re: WBEM not working

The primary purpose for WMI in HP SIM at this point is for communications with non-HP servers running Windows. While you can get some information from a ProLiant running Windows through WMI, this is going to be generic OS information and not feature any of the ProLiant value-add functionality or alerting.

It should not be necessary to install the WMI Mapper on each and every system.
Rene Nascimento
Frequent Advisor

Re: WBEM not working

Thank you Chez! I downloaded WMI mapper 2.3 from HP and installed it on my 2003 server. I now have the properties tab under the System tab and it's displaying WBEM data now.