Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

[WIN]HP Sim 7.1 : doesnt work since password change

Bruniche
Advisor

[WIN]HP Sim 7.1 : doesnt work since password change

Hello,

 

I run HP Sim 7.1 with SQL Express (the one include in setup) on a Windows 2008 R2.

The service run with my entreprise admin account.

All works find (to begin to understand the software before a real install) until i change my password (due to entreprise password policy).

 

Still HP SIM doesnt work.

 

a) i change the password on services SQL & HP SIM.

b) i launch the "mxpassword.exe -g" and change the password too.

 

But still, the service start well but didnt work.

* i cant access to http://localhost:50000

* if i launch mxpassword again, the command freeze (but not 100%CPU or memory, the process give nothing)

* no error in event log windows

* in HP SIM log (i dont have it cause i'm at home) but no specific error : the last line is (from my memory) JAVA MULTIPLEX START (something like that).

 

Have you an idea how to resolv this issue ?

 

Regards,

 

 

4 REPLIES
Tushar Bajpai
Trusted Contributor

Re: [WIN]HP Sim 7.1 : doesnt work since password change

check with cli: mxgetdbinfo

 

Reset password:
mxpassword -g
mxpassword -m -x MxDBUserPassword="<new-password>"

 

i.e To change the current database password to rocketboy2, enter mxpassword -m -x
MxDBUserPassword=rocketboy2

 

Modify service account on Control Panel -> Services -> HP System Insight Manager, then stop the service.
Edit file \config\database.props.
modify the following line:
hp.Database.username=domain\\new-account

 

Start HP SIM service. That’s all. 

if it helped, award me Kudos or Points. Thanks :)

\T Bajpai
HP Employee

Bruniche
Advisor

Re: [WIN]HP Sim 7.1 : doesnt work since password change

Hello,

 

Thanks to you return, but that doesnt work.

 

The configuration account is always the same, just the password change.

 

Here the log of mxdomainmgr:

10:59:17,094 INFO  [Server] Starting JBoss (MX MicroKernel)...
10:59:17,094 INFO  [Server] Release ID: JBoss [Trinity] 4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)
10:59:17,094 INFO  [Server] Home Dir: C:\Program Files\HP\Systems Insight Manager\jboss
10:59:17,094 INFO  [Server] Home URL: file:/C:/Program Files/HP/Systems Insight Manager/jboss/
10:59:17,094 INFO  [Server] Patch URL: null
10:59:17,094 INFO  [Server] Server Name: hpsim
10:59:17,094 INFO  [Server] Server Home Dir: C:\Program Files\HP\Systems Insight Manager\jboss\server\hpsim
10:59:17,094 INFO  [Server] Server Home URL: file:/C:/Program Files/HP/Systems Insight Manager/jboss/server/hpsim/
10:59:17,094 INFO  [Server] Server Log Dir: C:\Program Files\HP\Systems Insight Manager\jboss\server\hpsim\log
10:59:17,110 INFO  [Server] Server Temp Dir: C:\Program Files\HP\Systems Insight Manager\jboss\server\hpsim\tmp
10:59:17,110 INFO  [Server] Root Deployment Filename: jboss-service.xml
10:59:17,703 INFO  [ServerInfo] Java version: 1.6.0_27,Sun Microsystems Inc.
10:59:17,703 INFO  [ServerInfo] Java VM: Java HotSpot(TM) 64-Bit Server VM 20.2-b06,Sun Microsystems Inc.
10:59:17,703 INFO  [ServerInfo] OS-System: Windows Server 2008 R2 6.1,amd64
10:59:18,375 INFO  [Server] Core system initialized
10:59:21,547 INFO  [WebService] Using RMI server codebase: http://127.0.0.1:50013/
10:59:21,563 INFO  [Log4jService$URLWatchTimerTask] Configuring from URL: resource:jboss-log4j.xml
27 Dec 10:59:27,141 INFO  [EJB3Deployer] Starting java:comp multiplexer

 

and nothing else. No error in event log or anywhere else.

And all the tools mx** (mxpassword or mxgetdbinfo) "freeze" (CPU is still at 0% and not use a lot of memory) but they waiting something i dont find. I launch a "procmon" and there is no a denied access somewhere.

Bruniche
Advisor

Re: [WIN]HP Sim 7.1 : doesnt work since password change

OK, i unlock the situation (but not sur why).

 

I suppress a globalsettings.props.lck file (in config folder) and inverse the globalsettings.props file with his backup file (globalsettings.props.bkp).

 

After that, tools mx* works fine and HP Sim started successfully.

I dont explain this error.

Tushar Bajpai
Trusted Contributor

Re: [WIN]HP Sim 7.1 : doesnt work since password change

Ok, got it. This was because of locking of the file. Apply the latest fix, the issue is addressed in that.

 

(HPSIM 7.1.1)

if it helped, award me Kudos or Points. Thanks :)

\T Bajpai
HP Employee