HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

WMI Mapper won't install

 
Brian Hahne
Regular Advisor

WMI Mapper won't install

No matter what version (2.4 or 2.5) that I try, Pegasus WMI Mapper will not install. I continually get errors about the service not starting in a timely manner. Any insight would be appreciated!
1 REPLY
Brian Hahne
Regular Advisor

Re: WMI Mapper won't install

OK I fixed it. What a nightmare.
I tried EVERY released version of WMI Mapper. All failed without starting the service. I then thought "Maybe WMI isn't installed on the system" or something.. I went to add/remove programs, and windows components. I got an error about wbemupgd.dll could not be loaded.

Looked at Microsoft, and found this page:
http://www.microsoft.com/technet/scriptcenter/topics/help/wmi.mspx

wbemupgd.dll wouldn't run, but WAS where it was supposed to be.

Which led me to this link:
http://support.microsoft.com/kb/838860

Edited the path, and it's fixed.
My error wasn't even that I had %systemroot% in there, I had C:\windows....
I was missing C:\windows\system32\wbem from the system path.

I added that, and it all works.
Pegasus 2.5 installed with no problem, service started.