Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

hp-health wont start - Citrix Zenserver 5.6 - HP ML150 G6

Rick_189
Occasional Advisor

hp-health wont start - Citrix Zenserver 5.6 - HP ML150 G6

I apologize, This message is a mess but here it is.

My system; zenserver 5.6 SP2 , HP - ML 150 G6


Below are error messages from logs and /etc/init.d/hp-snmp-agents restart command. I'm not sure what I am missing I've loaded all the HP management RPMs described in the HP System Management Homepage 6.0 guide. I also installed hp-OpenIPMI but messages appeared saying it wasn't needed so I removed it but still have errors. The webbase part of the install works and I can view the website in a browser. I installed the HP Insight Diagnostic plugin and am receiving info from the plugin.


This leads me to this question; what version of Redhat/Centos is Xenserver 5.6? Is it version 4 or 5? The reason I ask is I have been installing RPM's for Redhat V.5 but if you look below HP Insight Diagnostic says RH 4.1.
This is a message from HP Insight Diagnostic ; OS Version Linux version 2.6.32.12-0.7.1.xs5.6.100.327.170613xen (geeko@buildhost) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Mon Apr 23 09:48:30 EDT 2012.


Hope someone can help,
Rick

 

From the hpasmd.log it is telling me, “The file: /lib/modules/2.6.32.12-0.7.1.xs5.6.100.327.170613xen/build/.config
does NOT exist. There must be a Linux kernel”


From HP Insight Diagnostic - OS Version Linux version 2.6.32.12-0.7.1.xs5.6.100.327.170613xen (geeko@buildhost) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Mon Apr 23 09:48:30 EDT 2012

 

**********************************************************************************
/etc/init.d/hp-snmp-agents restart
Already stopped NIC Agent Daemon (cmanicd): OK 
Already stopped Storage Event Logger (cmaeventd): OK 
Already stopped FCA agent (cmafcad): OK 
Already stopped SAS agent (cmasasd): OK 
Already stopped IDA agent (cmaidad): OK 
Already stopped IDE agent (cmaided): OK 
Already stopped SCSI agent (cmascsid): OK 
Already stopped Health agent (cmahealthd): OK 
Already stopped Standard Equipment agent (cmastdeqd): OK 
Already stopped Host agent (cmahostd): OK 
Already stopped Threshold agent (cmathreshd): OK 
Already stopped RIB agent (cmasm2d): OK 
Already stopped Performance agent (cmaperfd): OK 
Already stopped SNMP Peer (cmapeerd): OK 
Trying to identify the Product Name... Done
Using Proliant Standard
IPMI based 1XX System Health Monitor

****

Warning: hp-OpenIPMI is not supported on this platform.
hp-OpenIPMI will not be used. It is safe to uninstall hp-OpenIPMI.
On RPM-based systems, you can remove hp-OpenIPMI by running:
'rpm -e hp-OpenIPMI'

****

Using standard Linux IPMI device driver
PCI BIOS is not detected!
Something went wrong
Starting Proliant Standard
IPMI based 1XX System Health Monitor (hpasmpld) FAILED
**********************************************************************************

/etc/init.d/hp-health: failed to start! Please review log file for details.
The log file locations are documented in the hp-health(4) man page.

/opt/hp/hp-ilo/check_install_kernel.sh
This kernel requires a rebuild. Seeking source files
Basic source files appear to be installed. Investigating further.
The file: /lib/modules/2.6.32.12-0.7.1.xs5.6.100.327.170613xen/build/.config
does NOT exist. There must be a Linux kernel
'.config' file with CONFIG_MODULES enabled to build this
package.
Unknown Linux Distribution - No Source to build

From Logs

cat /var/log/hp-health/hpasmd.log
Warning: hp-OpenIPMI is not supported on this platform.
hp-OpenIPMI will not be used. It is safe to uninstall hp-OpenIPMI.
On RPM-based systems, you can remove hp-OpenIPMI by running:
'rpm -e hp-OpenIPMI'

****

Using standard Linux IPMI device driver
Starting Proliant Standard
IPMI based 1XX System Health Monitor (hpasmpld):
hpasmpld: Failed to inialize HP iLO Code Interface: Bad address
cat /var/log/hp-snmp-agents/cma.log
Unknown Linux Distribution - No Source to build
Check installed kernel failed
Stopping hp-ilo:
hp-ilo: hpilo is not currently loaded.
Starting hp-ilo: This kernel requires a rebuild. Seeking source files
Basic source files appear to be installed. Investigating further.
The file: /lib/modules/2.6.32.12-0.7.1.xs5.6.100.327.170613xen/build/.config
does NOT exist. There must be a Linux kernel
'.config' file with CONFIG_MODULES enabled to build this
package.
Unknown Linux Distribution - No Source to build

tail /var/log/messages
Sep 18 13:09:28 xenserver-2 hpasmlited2698: OsKcsExecCmd: IPMICTL_SEND_COMMAND failed! (IPMI NetFN: 0x6, CMD: 0x1)
Sep 18 13:09:28 xenserver-2 hpasmlited2698: check_ilo2: Failed to get BMC Device Id!
Sep 18 13:09:28 xenserver-2 hpasmlited2698: CRITICAL ERROR: Requesting restart of HP Advanced System Management Stack!
Sep 18 13:09:36 xenserver-2 hpasmlited2703: hpasmlited: Invalid Option: ?
Sep 18 13:09:48 xenserver-2 hpasmlited2708: OsKcsExecCmd: IPMICTL_SEND_COMMAND failed! (IPMI NetFN: 0x6, CMD: 0x1)
Sep 18 13:09:48 xenserver-2 hpasmlited2708: check_ilo2: Failed to get BMC Device Id!
Sep 18 13:09:48 xenserver-2 hpasmlited2708: CRITICAL ERROR: Requesting restart of HP Advanced System Management Stack!

Edited by: Rick Morgan on Sep 18, 2012 2:51 PM

Edited by: Rick Morgan on Sep 18, 2012 2:53 PM

Edited by: Rick Morgan on Sep 18, 2012 2:54 PM

Edited by: Rick Morgan on Sep 18, 2012 4:33 PM

Edited by: Rick Morgan on Sep 18, 2012 4:38 PM