Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

iLO Power Management Licence issue

Greville Wild
Occasional Visitor

iLO Power Management Licence issue

Scenario:

We have purchased a single iLO Advance Pack and a single Insight Power Management Support Pack to evaluate the extent of the power monitoring capabilities.

Test Configuration:

Server : HP DL380 G5
O/S : Windows Standard Server 2008
64-bit
Networking : It's on it's own local network,
with a network address of
10.0.0.5.
: The iLO port is 10.0.0.1
SIM vers. : 5.2 SP1
iLO vers. : 1.50

From the Deploy / License Manager page lists

Lic'd Used Lic's
HP iLO Adv.Pack (Lic.v.1) 0 1
Insight Power Mgmnt (Lic.v.1) 1 1

NB: The Advanced Pack licence was applied, via cross-over cable, from a laptop connected to the iLO2 port.

Going through the following steps from the Deploy / License Manager page...

1) Select HP iLO
2) Select Manage Licenses button
3) Select iLO Available License radio button
4) Select Assign Licenses button

Assign licenses, step 1: Verify Target System
The tool will run on the following systems. if you are happy twith this selection, click "Next".

Name OS Type Tool Launch OK?
10.0.0.1 Embedded Mgmnt Proc Yes

Select next button....

Licence Assignment results:
System Name Response Status
10.0.0.1 Connection to device failed.
Possible reasons could be
device not reachable or device
is an older firmware version
of iLO.

I have referred to Customer Advisory c00850102.
The output from that is provided as an attachment.


For any assistance that may be provided - a BIG TIA.
6 REPLIES
V Deepak Kumar
Regular Advisor

Re: iLO Power Management Licence issue

Hey,
Ok am assuming you have applied the ILO Adcanced pack license succesfully on the ILO. Now you need to collect this licensing information in HP SIM and do to so.
a)Check if SSH is enabled on ilo2.
b) Check if ILO2 SSH port is same with the one SIM is trying to connect to ILO2
c) If yes try resetting the ilo2 SSH conncetions .
d) Now log into SIM and click All Managenet Processors
e) Select the MP in and run "Deploy-> License Manager" tool.
f) You will see list of prodcuts, Select HP ILO Advanced Pack and click "Collect License Info" . this will bring up a UI which will have your MP as the targets and now click Next
g)This will attempt to pop up a window [So make sure pop up is enabled for HP SIM].
h)In case the table in the window shows "Unable to detect credentials or Invalid credentials. Click here to provide valid credentials." for Response status column, Enter the MP credentials that you use to loginto MP Web interface by clicking the error message, Then Right click and refresh the window , this will again try to collect licensing information with new credentials.

Hope this works.
Let me know if you have more queries on licensing as well as power monitoring capabilities.
Thanks
Deepak





Performance is compulsion and not an option if my existence is to be justified.
V Deepak Kumar
Regular Advisor

Re: iLO Power Management Licence issue

Assuming SIM has collected Advanced ILO license later make sure Web Server SSL port is configured to 443 so that Insight Power Manager can communicate with ILO to show you the power capabilities of the server. For more details on what Insight Power Manager can do please refer
1) http://www.hp.com/go/ipm
2) In this page click
Support and Documents on your right under Support Section
3)Under Resources for HP Insight Power Manager Software click Manuals for all the details.

Hope this helps.
Thanks
Deepak
Performance is compulsion and not an option if my existence is to be justified.
Greville Wild
Occasional Visitor

Re: iLO Power Management Licence issue

Firstly Deepak, thanks ever so much for responding to my query.

In replying to your response:
The iLO licence has been applied successfully.
a) SSH is enabled on iLO2 - Port 22.
b) I think this is where I've tripped up.

After reading around the issue I suspect OpenSSH isn't available.

So, I've gone into "Deploy Drivers, Firmware & Agents | Install OpenSSH" and logged in.

Almost immediatly SIM reports that "cannot update SIM".

I'm somewhat stuck at this point. Could it be that SIM doesn't like the 64-bit element of Windows 2008 Server?

Also (when trying to apply OpenSSH) if I search for target 10.0.0.5 (the CMS server) SIM notes its system name as 127.0.0.252 and the system address as 10.0.0.5.

However, if I search for all systems, SIM reports that the CMS has the system name 127.0.0.252 but the system address is 127.0.0.247.

Is this right, because my gut feeling is that it isn't?

TIA.

Grev.
V Deepak Kumar
Regular Advisor

Re: iLO Power Management Licence issue

Hey,
You need to install Open SSH on the CMS and not by using Deploy Drivers. When you unpack SIM.exe [Setup] you will get a Open SSH component, Re-install this component on the CMS server and try again.

Thanks
Deepak
Performance is compulsion and not an option if my existence is to be justified.
Greville Wild
Occasional Visitor

Re: iLO Power Management Licence issue

Hi Deepak. Thanks for the response.

OK. Located Open SSH on the ICM DVD.

Went to install it and it was already there.

However, I'm having issues with cygrunsrv.exe.
Ostensibly it crashes every time it runs.

I understand this is required by SSH to run.

OpenSSH is shown within Windows' System COnfiguration
Services as start pending.

So, the service appears to be trying to run but
one of it's components refuses to behave.

Have you a workround for this.

Cheers,

Grev.

(Apologies for not providing ratings previously.)
Jolanta Sulima
Occasional Advisor

Re: iLO Power Management Licence issue

Hi Greville

It looks that I have very similar problem.
I have HP SIM 5.3 Sp1 with current updates (3-8)and I have error "Connection to device failed. Possible reasons could be device not reachable or device is an older firmware version of iLO." if I try to collect license info from Management Processor (iLO2 with FW 1.80 an 1.81).
SSH settings on managemnt processor are fine.
When I check - Manage connection on CMS server I have error on Open SSH instalation, but Open SSH is installed on this server.

Did you find solution for your problem? Can you share it?

Regards,
Jola