Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

management agent 8.10 install to ESX 3.5

Randy_Barbee
Occasional Visitor

management agent 8.10 install to ESX 3.5

I've installed this agent to my other hosts without issue but on a fresh install, I install the 810 agents without issue but when I go the local management page, I can log on but dont see any detail for my hardware. I've tried dropping the ESX firewall, uninstall/reinstall, restart snmpd, restart the host, etc. Does anyone have other troubleshooting steps I can try?

The last time I had an issues and called HP for support, it took 6 weeks to get someone on the phone that knew anything about the agents to help - I'd rather stick pencils in my eyes than go through that again if I can help it.

Thanks
5 REPLIES
Rob Buxton
Honored Contributor

Re: management agent 8.10 install to ESX 3.5

I'd start by searching this forum as a lot of questions have been asked about ESX and the HP Agents before.
Step 1 - has it been ID'd in HPSIM? If not then SNMP is not correctly set up.
Step 2 - use esxcfg-firewall --query, there should be 3 lines at the bottom for the hp agents. At the top there should also be an "ACCEPT" for port 161. That indicates th agents have installed.
step 3 check snmp and hp agents are running, enter:
/etc/init.d/snmpd status
/etc/init.d/hpasm status

When installing the HP Agents I always edit up the hpmgmt.conf file and use that in a silent install. Once right, all subsequent installs just work.
Randy_Barbee
Occasional Visitor

Re: management agent 8.10 install to ESX 3.5

I'm installing using the hpmgmt.conf that's worked for all my other servers. I don't think its an ESX firewall issue and I dropped that to all all traffin in/out.

I've not added it to SIM yet, just testing by hitting the local management page over port 2381.

I'll do some more searching on the forums. Thanks
Randy_Barbee
Occasional Visitor

Re: management agent 8.10 install to ESX 3.5

More info. I dont think the HP MIBs installed. When I run this I dont get any results.

snmpwalk -v 1 localhost -c public enterprises | grep hp
Randy_Barbee
Occasional Visitor

Re: management agent 8.10 install to ESX 3.5

I uninstalled the 810 agents and installed 811 and it all works fine now.
Rob Buxton
Honored Contributor

Re: management agent 8.10 install to ESX 3.5

Sounds good.
I usually just compare the example hpmgmt.conf file between releases to check for differences.
If there's none I continue to use the original one I created.