Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

mibItems table not populating

rcseattle
Frequent Advisor

mibItems table not populating


I have mibs that used to work and now don't since deleting and trying to readd them.

It appears the mibItems table is not populating when I re-import the mib and I'm unsure what to do with this now.

Any help is much appreciated.
3 REPLIES
rcseattle
Frequent Advisor

Re: mibItems table not populating


Apparently mibItems data was not properly deleted when the mib was removed.

The mib names were associated with a deleted mib file id, and the constraint on the table would not allow them to be readded.

I removed the mib once again, deleted the data associated with the originally deleted file id, and re-imported the mib.

Now all is functioning properly.
T. Hatlø
Advisor

Re: mibItems table not populating

Can you please give me some more information about how you

"removed the mib once again, deleted the data associated with the originally deleted file id, and re-imported the mib."

I've downloaded several versions of the Dell mibs, compiled (mcompile), registered (mxmib -a) and unregistered them (mxmib -d). Each time I have used different names like FromDell10892, org10892 etc..

The dcstorag.mib is fine but the 10892.mib doesn't work (no information in the "Mib variable name" drop-down list).
SIMUser
Occasional Visitor

Re: mibItems table not populating


I think I restarted the server when one of the processes seemed hung, adding or removing one of the mibs.

It had me quite confused for a long time until I connected to the SQL tables and tried to add data and got the constraint error.

Basically I hacked at the DB, but no longer recall the table names in question. This was way back in January I dealt with this.