Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

snmp traps do not show in events

Unix Administrator_5
Frequent Advisor

snmp traps do not show in events

I can not get the system generated traps to show up under events. I can get a "Generic Unregistered" event to show up sent from the commandline. I have used tcpdump and snmptrapd to verify that the traps are being received on the SIM server. I have tested by unplugging a power supply and sent the Test Trap from the "System Management" page.

I have configured the community strings, I have enabled "Accept unregistered events". Still no luck.

Version: Systems Insight Manager 5.3 with Update 1 - Linux
Build version: C.05.03.01.00

Any suggestions?
7 REPLIES
marsh_1
Honored Contributor

Re: snmp traps do not show in events

hi,

is this system discovered in hp sim ?

Rob Buxton
Honored Contributor

Re: snmp traps do not show in events

If I understand this correctly, traps are being sent to the HP SIM Server and received on the server but not being picked up by HP SIM.

I don't work with Linux, but on Windows HP SIM uses the default snmp handler. Similar issues are usually because something else is intercepting the traps.
Unix Administrator_5
Frequent Advisor

Re: snmp traps do not show in events

The systems have been discovered by SIM.

I have verified the CMS gets the traps using snmptrapd, but when I start SIM mxdomainmgr is listening on port 162 only the traps sent from the commandline get logged as events.

Is there any logs/debug that show what SIM receives?

Michael Leu
Honored Contributor

Re: snmp traps do not show in events

Did you check that trap handling is enabled in SIM Options -> Events -> SNMP Trap Settings?
Unix Administrator_5
Frequent Advisor

Re: snmp traps do not show in events

I think I figured it out. The client has two ips, frontend and backend. The HPSIM server knows it by the frontend ip, however when a trap is sent by Insight Manager on the client it gets tagged with the backend IP. How can I can I change this behavior? I have verified this is an issue by sending test traps with trapgen and snmptrap.

Unix Administrator_5
Frequent Advisor

Re: snmp traps do not show in events

Got it working.

I added

v1trapaddress IPofNICtoUse

to /etc/snmp/snmpd.conf. I restarted everything and viola it works. However, when I send a test page from the System Management Homepage settings snmpd page it still gets the wrong IP, but everything else is working
Unix Administrator_5
Frequent Advisor

Re: snmp traps do not show in events

Solved as stated above