Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

snmp traps fail

DigiDoc TechAdmin
Occasional Advisor

snmp traps fail

hpsim 6.2

Hello all.

I have the entries below in my mxdomainmgr.0.log
when snmp traps should get through.
The snmp trap service is running.
Does anyone know what this error means and how i can fix these traps getting through?
Other v1 traps work ok.

Regards,
Hoyte Swager


13 Feb 16:31:21,782 ERROR [STDERR] Feb 13,2011 4:31:21 PM com.hp.ov.nms.trapd.TrapHandler run
WARNING: exception in ConvertV2toV1 when parsing trap data. For input string: "No sendmail process running"
13 Feb 16:31:21,782 INFO [HPSIM_DEBUG] [Panic Logger-0] (ConstructionWrapper:TrapRequester) Trap service not functioning, enable or
start it
13 Feb 16:31:21,782 ERROR [STDERR] Feb 13, 2011 4:31:21 PM com.hp.ov.nms.trapd.TrapHandler run
WARNING: exception in ConvertV2toV1 when parsing trap data. For input string: "No httpd process running"
13 Feb 16:31:21,782 INFO [HPSIM_DEBUG] [Panic Logger-0] (ConstructionWrapper:TrapRequester) Trap service not functioning, enable or
start it
13 Feb 16:44:51,116 INFO [HPSIM_DEBUG] [Panic Logger-0] (ConstructionWrapper:ClearEvents) update alert ID 2,775 XML is null
13 Feb 16:44:51,116 INFO [HPSIM_DEBUG] [Panic Logger-0] (ConstructionWrapper:ClearEvents) update event-converted ID 2,775 XML is nu
ll
13 Feb 16:44:51,194 INFO [HPSIM_DEBUG] [Panic Logger-0] (ConstructionWrapper:ClearEvents) update alert ID 2,787 XML is null
13 Feb 16:44:51,194 INFO [HPSIM_DEBUG] [Panic Logger-0] (ConstructionWrapper:ClearEvents) update event-converted ID 2,787 XML is nu
ll

 

 

P.S.This thread has been moved from  Insight Remote Support>general to ITRC HP Systems Insight Manager Forum- HP Forums Moderator

3 REPLIES
BPE
Esteemed Contributor

Re: snmp traps fail

Could it be that your server is also or was once a HP NNM server? In this case the trap handler is replaced with a HP NNM version.

I would enable unregistered events in the event filter menu. "No send mail process running" could indicate that an older insight agents could be the source of the trap.
DigiDoc TechAdmin
Occasional Advisor

Re: snmp traps fail

Thank you for the quick answer.
This is however a newly installed proliant server with a fresh install of only hpsim, so no hp nnm.
The trap comes from the net-snmp disman-event-mib when defaultMonitors is set to yes on linux hosts running net-snmp.
Somehow the error seems to indicate something is going wrong with the conversion of v2 trap to v1?
Regards,
Hoyte Swager
Richard Munn
Frequent Advisor

Re: snmp traps fail

I am seeing the same problem on HPSIM V6.3 (Hotfix Jun 2011).

The input string is simply "  ".

The devices it is comming from does send V2 traps (whatever they are) and do not get through. There are 3 of these devices and all do the same.

All other systems (many) sending V1 traps are fine.