Servers - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Convex Exemplar 1200

 
SOLVED
Go to solution
Witte, Ernst Martin
Occasional Advisor

Convex Exemplar 1200

Hello!

(please forgive me, if this message is OT here, but I don't know any other forum at the HP-ITRC where to post my problem;)

To our students dormitory network (Aachen, Germany) an old convex exemplar 1200 system was donated, unfortunately with an incomplete set of software and documentation. The installation DAT tapes (SPP-UX 5.3.1 upgrade package) can not be used with the current firmware and teststation software, the upgrade of the teststation software with the 5.3.1 tapes failed, because the new tools seem to need some libraries not present on our teststation (/usr/lib/dld.sl, /usr/lib/libc.1, and possibly more)

So we are not able to install the system from scratch.

According to the convex homepage, HP is now responsible for support. The attempt of registration on http://www.convex.com had no success: we did not get any answer since then (january). After some mails with the HP-ITRC-Team I got no result, too, except the proposal to use one of these forums.

What our students initiative is looking for is someone who can provide us with concrete ideas, how to get (at no charge, we are poor students:) access to the software and documentation necessary to install our convex exemplar 1200 system and teststation properly.

Thanks in advance for your help,

Martin
13 REPLIES 13
Patrick Wessel
Honored Contributor

Re: Convex Exemplar 1200

Hello Ernst Martin,

Lets start with the bad news, the SPP1200 is out of support!

A missing dld.sl on the Teststation looks like a serious HP-UX problem with the Teststation. I assume, it's a 712 running an hp-ux 9.0x version, right? You should see this separated from your SPP1200 and handle it as a usual Workstation with an OS problem. In other words, describe your Problem with the workstation, don't motion the word Convex or SPP and throw it in the shark tank of the hp-ux forum. (Btw, hp-ux 9.0x is no longer supported and not Y2k compliant)

I called a colleague who worked originally for Convex. He will dig through his old tapes and see what he can do for you. But he is almost sure that he already threw everything away that could help.
Maybe you could knock on the door of the Uni Leipzig or Uni Mainz. They originally had an SPP1200, too

Good Luck,
Patrick
There is no good troubleshooting with bad data
Witte, Ernst Martin
Occasional Advisor

Re: Convex Exemplar 1200

Hello!

Thanks for your answer, Patrick.

Our Teststation is a 712/60. We have two harddisks: One with the original HP-UX 9.05 installation and SPP-UX-Tools 4.2 (now 5.3.1). On this system the libraries are missing, though /usr/lib/libdld.sl (ln -s libdld.sl dld.sl helps) and /usr/lib/libc.(a|sl) (symlink does not help) exist.

On the other harddisk, shipped as Y2k-Upgrade, HP-UX 10.20 is installed, with SPP-Tools 5.3.1. But the documentation says: "Test Stations running 10.20 are not supported for connection to SPP 1200/1600 Exemplar Systems". And that's the problem: The Exemplar Node's MAC-Address is in the arp cache, but the tools do not recognize any node.

I think, this behaviour is a bit strange for a simple Y2k-Update. (BTW, the systems are running in 1999:)


Bye, Martin
Ralf Dammass
Occasional Advisor
Solution

Re: Convex Exemplar 1200

Hallo Mr. Witte,

1st: don't care about 10.20 HPUX on the teststation. This is supported and required for Y2K
2nd: Boot the teststation using the 10.20 disk.

login as root on the teststation and run /spp/scripts/inst/ts.install

when finish reboot the teststation and power cycle the the SPP1200

After this you should be able to ping the mu-0000 (see /etc/hosts)

If possible I can have a quick view next Monday on the teststation to get it running.

Is a remote dialin to the teststation possibl,

best regards

ralf Dammass
Witte, Ernst Martin
Occasional Advisor

Re: Convex Exemplar 1200

Hello Ralf!

Thank you for your answer, it helped to reestablish the connection to our convex system under hp-ux. Today we successfully upgraded the firmware. But unfortunately the convex cannot boot any more from the DAT drive (with the old firmware, it read some data from the tapes at least). When we type

boot rmt0

(nvalias rmt0 /mbus@.... is set)

we get an error message like

"fatal scsi error: script at c0000010: unexpected device disconnect
can't open boot device"

or something link this, I can't remember that exactly. All successive tries to boot with "boot rmt0" just end with "can't open boot device", there are no more "disconnect"-messages.

What does that mean? This error did not occur with the old firmware. The hardware configuration was not changed.

Is there some configuration we missed to set? Or is OBP 2.0.4 /FW 8.2/PL8.2 buggy?

Bye, Martin

Ralf Dammass
Occasional Advisor

Re: Convex Exemplar 1200

Hello Ernst Martin,

As far as I remember, there is n option to boot the SPP1200 direct from tape. You have to have a bootable disk in. In most cases customer had 2 independent disks with a operating system installed. Either you know the path for the bootdisk or try to get the system booted from all installed disks. There is no other way to find the bootable disk.
In case you have the software tapes as well, be aware you need for several applications the flexlm-keys.

best regards

Ralf
Witte, Ernst Martin
Occasional Advisor

Re: Convex Exemplar 1200

Hmm... I'm sure, the convex exemplar 1200 is/was able to boot from tape. Before upgrading the firmware we successfully bootet from the "scratch install" tape. The only problem was the incompatibility with the firmware, so the script failed after some questions during the hardware detection.

Is there any way to check the functionality of a DAT drive within an open boot prompt? And what is exactly the device mapping? Is that necessary for accessing a device during bootup or is that only needed under SPP-UX?

Bye, Martin
Ralf Dammass
Occasional Advisor

Re: Convex Exemplar 1200


Hello Ernst Martin,

..it is a long time ago I worked with the SPPs.
It looks like something is wrong with the rmt0 string. probably the device is not mapped. First thing we should check here is if there is a mapping for the rmt0 and if it is there, does it match the current installed hardware.

at the obp do the following:

1st show-devs
here you should see a string like
/mbus@x,yyyy...... ..afws@1,10000/st

2nd show-map rmt0 (to get the mapping for rmt0)

to be on the safe side, do a boot and as the boot device you choose the complete string you find for the DAT.

If the mapping is missing , create the map like
mkmap 0 devicestring seen at show-devs output

If the mapping is wrong, use the rmmap command as follows
rmmap devicestring seen at show-devs output

If there is still a problem, check the ccmu-parameters:

in a sppdsh-window call ccmu:
ccmu>> up
ccmu >> get INITWHAT
ccmu >> get RUNWHAT
ccmu >> quit

let me know this paramenters as well, the number of CPUs, memory boards type of IO-board.

Ralf


Witte, Ernst Martin
Occasional Advisor

Re: Convex Exemplar 1200

The mapping and devalias is set as it was before the firmware upgrade.

Node configuration:
2GB Memory (512 per board),
8 CPUs, 1 IO-Board: type unknown or landmark(?), 2 SCSI busses

The InitWhat-Value is set to 0x5880cf0f (StartPL, PLCPUInit, PLInitMJem, PLLoadOBP, MUErrEnable, InitLand, InitSlice[0-3], InitXBar, DoReset, PwrClkCheck, Go

The RunWhat is set to 0xf30f7eff (MB[0-3], XBar_Q, XBar_S, CCMC[0-3], TChip[1-6], CPA[0-3], IO[0,1], MAUI, MU)

If selected (not the case in the above configuration) TChip0 and TChip7 are marked red (missing? damaged?) by xconfig though the CPUs are present. Same with MAUI and XBars (cannot be disabled). The old version (8.0) of xconfig displays MAUI and XBars as preset (yellow).

What is exactly the job of the xbar components? Are they necessary for a single node?

While comparing settings before and after firmware upgrade (printenv at OBP prompt) we noted that the unit-map setting is set to

00 4a 00 00 00 ...

though it was

80 42 00 00 00 ...

before.

What does this value mean, how can it be set (obp short reference says: do not set this value directly), how can it be displayed completely (seems to consist of several bytes, only 4-5 are displayed)

Bye, Martin
Ralf Dammass
Occasional Advisor

Re: Convex Exemplar 1200

Ernst Martin,

1st: It looks like your ccmu parameters screwed up. INITWHAT is in your system 0x5880cf0f but it should be 0x5882cf0f .
Currently you don't initialize main memory.
RUNWHAT looks strange as well. There are 2 CPU's missing.

try the following:
ccmu>> up
ccmu>> auto
ccmu>> down
ccmu>> push
ccmu>> quit

after this reinvoke ccmu and check the following parameters:
INITWHAT
RUNWHAT
NODEID
ASSERTRESET
DEASSERTRESET
USEMEMSIZE
USEBANKFIELD
USECACHESIZE
STATUSMU
APPLY_POWER
MUCONFIG
AVAIL_HW
HW_CONFIG

I hope the auto command will help. Otherwise let me know the output.

Along your question for XBAR: you need the XBAR for the packet routing between the memory controller(CMC), the CPU agants (CPA) and the IO (MAUI controlls this as well).

Along the uni-mapping I don't have an answer right now. It need some more investigations. At the bottom line I believe we have to get the ccmu paraments fixed at first.

Ralf
Witte, Ernst Martin
Occasional Advisor

Re: Convex Exemplar 1200

INITWHAT contains just 0x5880cf0f, setting it to 0x5882cf0f does not solve the problem. What is the difference between PLInitMem and InitMem?

The problem with CPU0 and CPU7 is solved, they were not plugged in properly, now they are running. BTW, io_tc is passed.

The Values:
INITWHAT 0x5880cf0f
RUNWHAT 0xf30fffff
NODEID 0
ASSERTRESET 0xffffffff
DEASSERTRESET 0x030fffff
USEMEMSIZE 4 (=> 2 GB)
USEBANKFIELD 4
USECACHESIZE 0
STATUSMU 0x00000080
APPLY_POWER 0x00007fc7 (IO, VEE_Clk, VHE_HP, VHC_HP, VCC_MB[3-0], VTT, VDL, VDD_GA)
MU_CONFIG 9 (Info_Events, Scurb)
AVAIL_HW 0x800f1fff (Node, Slice[3-0], IO, MB[3-0], TChip[0-7])
HW_CONFIG 0x0000ff19 (Mem[3-0]_Bank_[0-1], CMC3_Fairness_Disable, SCI4_Installed, CMC_Dark)

Bye, Martin

Ralf Dammass
Occasional Advisor

Re: Convex Exemplar 1200

Ernst Martin,

sorry for the delay. PLinitMen initalizes the memory region for ther primary loader, InitMem the whole memory.

As you can imagin at OBP is is very easy to screw up a system. It is hard to troubleshoot on a "email" basis.

I would suggest to do the following:

1st try again to boot either the installed operating system on hard disk (one of the hard disk should have a bootable system) or try to boot from DAT by using the following command line:

bo /mbus@x,yyyy...... ..afws@1,10000/st

the exact string for the tape you find at OBP using show-devs.
Same procedure can be used for booting from disk.

2nd: if it is still an problem to boot from disk/tape (verifyed good tape) then we should start to "play" with the OBP parameters. try to use the command at ccmu
>> setenv INITWHAT 0x5882cf0f
>> down
>> push
>> quit

Otherwise I afraid a remote login to the teststation is required.

Ralf
Witte, Ernst Martin
Occasional Advisor

Re: Convex Exemplar 1200

Hello Ralf!

I'm sorry not having answered for such a long time. There was much stress at university for the last months. In our dormitory we finally managed to connect the room where the convex is to our lan and thus to the internet. So a remote login is now possible.

I suggest to discuss further details by mail. My email address is witte@kawo1.rwth-aachen.de.

I'll be glad if you try to help us once again :)

Bye, Martin
Clint Kennedy
Occasional Visitor

Re: Convex Exemplar 1200

I too have a Convex Exemplar SPP-1200/16 in a garage near me. Problem is, I have no media or documentation. Could someone help me to get copies of the 4mm tapes. I would need the "Teststation" software too. Many thanks, just the same.