Servers - General

HPE Microserver Gen10+ SATA Speed problem

 
Richie-Kotzen
Occasional Visitor

HPE Microserver Gen10+ SATA Speed problem

Hi, I have a problem on my microserver gen10+ .
Configuration:
Intel (R) Xeon (R) E-2236 CPU @ 3.40GHz
2x16GB DDR4 2666 HP 879527-091
1 nvme Samsung 970evo 1TB on PCIE adapter
4 Samsung 850evo 500GB SSD

Firmware last upgrade.

The disks are currently configured in AHCI mode for run esxi 670.U3.10.6.0 (HPE image).
The first problem is that in ILO5 "System Information - Storage Information" the wrong size reported on SATA disks (they should be GB and not MB, but maybe it's just a bug of the Agentless Management Service). 

The biggest problem is related to the writing speed is very low. I also tried with HDD, but write performance is much lower than what I get on other machines with same disk. Any idea what it could be?
I also tried to install the esxi 7.01 image, but the problem remains.

For test, I installed Windows 2019 Server as main machine, so not a VM under esxi. Installed on the same sata SSD that was giving poor write performance under esxi. Under Windows 2019 Server, however, the performance is correct, in line with the performance of the SSD (550MB / s writing and 550MB / s reading). 
Clearly technical support cannot answer me as there are no HPE disks mounted.
Do you have any idea how it can solve? Could it be a problem of non-optimized esxi SATA drivers?

Thank you!

2 REPLIES 2
ShruthiSK
HPE Pro

Re: HPE Microserver Gen10+ SATA Speed problem

Hello, 

Please let us know what is the tool that you are using to measure the speed wrt ESXi and Windows.

Kindly share the screenshots for the same. 

BR,

Shruthi

I am an HPE employee
Accept or Kudo
Richie-Kotzen
Occasional Visitor

Re: HPE Microserver Gen10+ SATA Speed problem

Hi Shruthi, I use crystal disk mark (test 1GB and 8GB), 

I am attaching some screenshots of the server and benchmark:

Firmware server -> https://ibb.co/JrscbFh
Error disk size (465MB ?! disk size is 465GB) -> https://ibb.co/hRMX3jg
Benchmark -> https://ibb.co/59VPnmv

Now I have tried with esxi to passthrough the AHCI SATA controller and the disks now perform correctly.
I therefore assume that it is either a problem with the AHCI drivers on esxi (as I said I tried both HPE images and not, going from 6.5 to 6.7 up to 7.01) or some firmware update that generates incompatibility.