Servers - General
cancel
Showing results for 
Search instead for 
Did you mean: 

InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

 
SOLVED
Go to solution
MarioE
Frequent Advisor

InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Hello Community

I want to configure InfoSight for Servers using the HPE iLO Amplifier Pack.
I do everything according to "HPE InfoSight for Servers - Getting Started Guide".
On our proxy server I opened the DNS port midway.ext.hpe.com:443.
However, I always get the error:

Connection Failed - Failed to establish connection to midway server. Check the network settings(Proxy/DNS) and retry.

in the iLO Amplifier Pack under HPE InfoSight (see Printscreen).

According to our firewall/proxy specialist, iLO Amplifier Pack tries to communicate via the IP address and not via the DNS name midway.ext.hpe.com, which of course does not work.

Does anyone have any experience with registering InfoSight for Server?

 

I have a HPE OneView in use which turns remote support into HPE. It also opened proxy ports to communicate with HPE. This works without problems.

10 REPLIES 10
ronissac
HPE Pro

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Hi MarioE , 

If you have a Proxy server, you must configure it in ILO amplifier Pack for ILO amplifier to communicate with HPE InfoSight 

Please follow the below procedure to configure the Proxy server

1. In iLO Amplifier Pack, click Configuration and Settings on the left navigation menu, and then click Network Settings.

2. Click the Proxy Configuration tab.

3. Click to select the Enable Proxy check box.

4. Enter your proxy server information:

 a. Enter your proxy server name in the Proxy Servername field, in the following format: .

 b. Enter your proxy server port number in the Port number field. Setting up HPE InfoSight for Servers (

IMPORTANT:       You must have an HTTPS port (443 or another valid port number) open between iLO Amplifier Pack and HPE InfoSight.

5. Select Enable Secure Proxy Connection.

6. To save your settings, click Save. 7. To restart the system, click Reboot.

 

If you feel this was helpful please click the KUDOS! Thumbs below!

Regards

Ronny

I am an HPE employee
ronissac
HPE Pro

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Hi MarioE

Please let know if this issue is resolved 

This is will help everyone following this thread

 

If you feel this was helpful please click the KUDOS! Thumbs below!

 

Regards

Ronny

I am an HPE employee
MarioE
Frequent Advisor

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Hi Ronny

Thanks for the information.
Of course I configured the proxy.
I have, as already written, other systems which communicate via the proxy. Until now I never had any problems, only with the HPE InfoSight with iLO Amplifier Pack.
As already mentioned:

According to our firewall/proxy specialist, iLO Amplifier Pack tries to communicate via the IP address and not via the DNS name midway.ext.hpe.com, which of course does not work.

ronissac
HPE Pro

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Hi MarioE , 

 

The primary DNS port is midway.ext.hpe.com:443. HPE highly recommends using 
the midway.ext.hpe.com DNS name to avoid future connectivity problems when the below IP
addresses change. However, if your firewall does not support DNS entries, you must open the
following IP addresses. These addresses are subject to change.

 

As of January 2019, the following IP addresses must be open to allow communication with HPE InfoSight
for Servers:
midway.ext.hpe.com 15.211.158.66
midway.ext.hpe.com 15.211.158.65
midway.ext.hpe.com 15.203.174.95
midway.ext.hpe.com 15.203.174.94
midway.ext.hpe.com 15.241.48.252
midway.ext.hpe.com 15.241.136.80
midway.ext.hpe.com 15.203.174.96
midway.ext.hpe.com 15.241.48.100
midway.ext.hpe.com IPv6 address 2620:0:a13:100::105
midway.ext.hpe.com IPv6 address 2620:0:a12:100::106
midway.ext.hpe.com IPv6 address 2620:0:a13:100::108

If you feel this was helpful please click the KUDOS! Thumbs below!

 

Regards

Ronny

 

I am an HPE employee
MarioE
Frequent Advisor

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Hi Ronny

I have read the document "HPE InfoSight for Servers - Getting Started Guide".
Our proxy does DNS resolution. Apparently the iLO Amplifier Pack Appliance communicates with the IP address, not with the DNS name midway.ext.hpe.com.

ronissac
HPE Pro

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Hi MarioE , 

 

The ILO amplifier does communicate using the DNS name.

Only when your firewall does not support DNS entries, does the ILO amplifier attempts to communicate via IP address. Kindly check with your network team and if you have any pending queries, Please log a support ticket with HPE so we may check your environment.

 

Regards

Ronny

I am an HPE employee
SzTibi
Occasional Visitor

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Hello Guys,

We are fighting with the same issue at customer site.

We are also behind a proxy server and firewall.

Checked all the hostnames - they are resolved by the DNS server
iLO Amplifier's requests appear in proxy server log. iLO Amplifier is allowed via firewall for secure connection. No limitations, no restrictions..
Proxy server allows both secure and unsecure connections. Tested with and without "enable secure communication" settings - No difference in results of registration.

We have an opned support ticket. We receive suggestions regularly but the issue is still not solved.

Regards,

SzTibi

MarioE
Frequent Advisor

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Here's the extract from the proxy:

February 27th 2019, 16:13:21.000,"<iLO Amplifier Pack IP Address>","infosight.hpe.com","tcp://infosight.hpe.com:443/"
February 27th 2019, 16:13:23.000,"<iLO Amplifier Pack IP Address>","infosight.hpe.com","ssl://infosight.hpe.com:443/"
February 27th 2019, 16:13:29.000,"<iLO Amplifier Pack IP Address>","[2620:0:a13:100::108]","tcp://[2620:0:a13:100::108]:443/"
February 27th 2019, 16:13:29.000,"<iLO Amplifier Pack IP Address>","15.203.174.94","tcp://15.203.174.94:443/"
February 27th 2019, 16:13:29.000,"<iLO Amplifier Pack IP Address>","15.203.174.95","tcp://15.203.174.95:443/"
February 27th 2019, 16:13:29.000,"<iLO Amplifier Pack IP Address>","15.211.158.65","tcp://15.211.158.65:443/"
February 27th 2019, 16:13:29.000,"<iLO Amplifier Pack IP Address>","15.211.158.66","tcp://15.211.158.66:443/"

Why does the HPE iLO Amplifier Pack Appliance connect to infosight.hpe.com? The "HPE InfoSight for Servers - Getting Started Guide" says: "The primary DNS port is midway.ext.hpe.com:443"?

nslookup infosight.hpe.com
Name: infosight1.itcs.hpe.com
Address: 16.248.65.16
Aliases: infosight.hpe.com

nslookup midway.ext.hpe.com:
Name: midway.ext.hpe.com
Addresses: 2620:0:a13:100::108
          2620:0:a13:100::105
          2620:0:a12:100::106
          15.211.158.65
          15.241.48.100
          15.211.158.66
          15.203.174.95
          15.203.174.96
          15.203.174.94
          15.241.136.80
          15.241.48.252

After the appliance tries to resolve to infosight.hpe.com twice, it then goes over the IP addresses of midway.ext.hpe.com, which of course doesn't work.

Something is wrong with the appliance.

MarioE
Frequent Advisor

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Hello @SzTibi 

you could solve your problem with InfoSight for Servers. What kind of suggestions did you get from HPE?

Thanks for your feedback.

Regards,

Mario

 

MarioE
Frequent Advisor
Solution

Re: InfoSight for Servers - Registration Failed (Proxy/DNS Problem)

Today I got an update of the iLO Amplifier Pack from


Version :1.30
Build :31
Date :Dec 20 2018


to


Version :1.40
Build :21
Date :May 31 2019

Now the connection to HPE Infosight works.