Service Manager / Service Center Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

KB base (9.30 SOLR) not searching documents

SOLVED
Go to Solution
Valued Contributor [Founder]

KB base (9.30 SOLR) not searching documents

Hello experts,

 

I install, configure and publish KM documents correctly.

 

Im having an issue with the search, when i search  with no parameters, i got all the publish documents in the KB, but when i use a word in any document, im not getting any results.

 

 

Thanks for any help you can give me.

 

Att:

Federico Chaves

Best Regards,

Federico Chaves
6 REPLIES
HPE Expert

Re: KB base (9.30 SOLR) not searching documents

Hi Frederico

Has the Script libraries associated with Solr been changed?

 

When you search on words is it any word that is in the doc title?

 

Thank you

LIsa

"HP Support
If you find that this post or any post resolves your issue, please make sure to mark it as an accepted solution."
HPE Expert

Re: KB base (9.30 SOLR) not searching documents

Hi

I found a KM article that might help

 

Example to search for documents in the Knowledge Library that contain the word "computer" in the title and have locale Spanish.

Assuming the Search Engine is running correctly and the library has been indexed.
Go to the URL for the SOLR
http://<Search_Engine_server_IP>:<Search_Engine_Port>/KMCores/Knowledge_Library/admin/

In the Query String box, enter the query (NOTE: the query is case sensitive):
title:"computer" AND locale:"es"

The result is in XML format, but readable nevertheless and allows to verify the query. This is useful when troubleshooting to verify if there's a problem indexing or the problem is searching in SM

 

Does it work this way ?

 

Thank you

Lisa

"HP Support
If you find that this post or any post resolves your issue, please make sure to mark it as an accepted solution."
Valued Contributor [Founder]

Re: KB base (9.30 SOLR) not searching documents

Hello Lisa.

I apply APPS patch 3 (9.30.03) so i could use different date formats, other than that nothing.

Yes, even when i search for words in the title.

I have currently this setup:
RTE: 9.30.021
App: 9.30.03
Spanish LP Installed, english disabled.

Thanks for any help you can give me.
Best Regards,

Federico Chaves
Valued Contributor [Founder]

Re: KB base (9.30 SOLR) not searching documents

Hello Lisa,

Really apreciate your help.

I try directly on the KM server and got no results,
my search string is:

title:"TITULO" and locale:"es"

and i got:
<?xml version="1.0" encoding="UTF-8" ?>
- <response>
- <lst name="responseHeader">
<int name="status">0</int>
<int name="QTime">0</int>
</lst>
<result name="response" numFound="0" start="0" />
</response>


Thanks for any help ypu can give me.
Best Regards,

Federico Chaves
Valued Contributor [Founder]

Re: KB base (9.30 SOLR) not searching documents

Hello,

 

I changed the locale in my kmdocument table to "en" and it started working :)

 

Thanks for your input :)

Best Regards,

Federico Chaves
Highlighted
HPE Expert

Re: KB base (9.30 SOLR) not searching documents

Great News

Let us know if we can assist with anything else

 

Lisa

"HP Support
If you find that this post or any post resolves your issue, please make sure to mark it as an accepted solution."