Service Manager / Service Center Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

SM Client on Windows 7 64bit

Occasional Visitor

SM Client on Windows 7 64bit



I have installed SM Client on Windows 7 64bit. The installation itself was no problem but when I open the SM Client and go to the Connections Manager/Configuration screen I am unable to add new connections. The icon (page with plus sign) is grayed out.


I have tried both the 7.11 and 9.2 Client (newest versions of each) and both have exactly the same problem.


As a work around I have configured the needed connection an a 32bit system and then copied the ServiceManager folder (found in C:/users/{my username}/ServiceManager) and this allows me to use quick connect (File -> Connection -> select connection 1,2,3,4 ....). This works but I am unable to add new connections or edit copied connection in the SM Client running 64bit.


Everything else works perfectly. I have tried both the 64 and 32 bit version of Java and starting SM Client in different compatibility modes (XP, Vista ....) and Run as Administrator and nothing helped.


Anybody have any Ideas?


Thank you



Regular Advisor

Re: SM Client on Windows 7 64bit

Hi Philip


If I understand you right your connection window is completely empty/white where you would normally at least see 1 connection setting.

I have seen this before with Windows 7 as well as Vista. Unfortunately I don't recall how we fixed this but it somewhat rings some bellows in regards to:

- we tried reinstalling

- access to the path the files are saved (maybe even modify to save your settings into the your profile and not into the public one)

- have you installed it into the "program files (x32)" directory or did you modify that part?


That the installation is on 64bit should not have an influence as SM is a 32bit program no matter what. I am running SM (7.11 and 9.20) on Win7 64 since almost a year and never had that issue.


If I remember how this was fixed at my end I will let you know :-)


Occasional Visitor

Re: SM Client on Windows 7 64bit

Hello Philipp,


I have searched the ITRC forums for a solution and there have been people with same problem. The solution seems to be to use a new version of the client. I have tried 9.20.021 and 7.11.281 and both have this problem for me.


Can you tell me if you are using any compatibility mode when running or installing the client in Win7 64bit? 


I will experiment a bit and see how it goes. I have so far left everything at default when installing. I will see how it goes.



Honored Contributor [Founder]
Regular Advisor

Re: SM Client on Windows 7 64bit



I don't use the compatibility mode functionality. I know of one case where a reinstallation helped. (don't ask me why though :-))



Trusted Contributor

Re: SM Client on Windows 7 64bit

I wonder if there is an issue with 64 bit vs 32 bit. When we were setting up 7.11 on our servers, we had to make certain that we created 32 bit ODBCs so that things could communicate appropriately between client - server - sql server.

Honored Contributor [Founder]

Re: SM Client on Windows 7 64bit


Same solution seems to be for SM 9.20 on 64 bit system. In one Russian printed document was solution like installing odbc for 32 bit system and making connections via it.

Senior Member

Re: SM Client on Windows 7 64bit

Hello Philip,


Did you manage to resolve this ? Let me know the solution for this problem.




Regular Advisor

Re: SM Client on Windows 7 64bit

Hi Charan


Not sure if this is a fix for you. But there is a compatibility issue with different server versions and clients version.


To resolve this you can delete the properties/connection folder on your windows user settings. It is the following folder:


Deleting this folder will clear all "client specific" settings and give you a new connection window.


As stated I have not run into the initial issue described in this post anymore ... so not sure if the above really helps you :-)




Re: SM Client on Windows 7 64bit



I can not create new connections on HP SM client 9.21 installed on Windows 7 (64bit)

I have tried compatibility changes, reinstalling client, Deleting user specfic settings i.e. C:\users\user_name\ServiceManager

 still having same problem.

Honored Contributor [Founder]

Re: SM Client on Windows 7 64bit

[ Edited ]


If you are trying to install HP SM client on Windows 7 then you have to run silent install.


In command line navigate to the setup file folder and then type setup.exe -silent (if setup file name vary from setup - print it)



Solution is:

1. Change in properties of the setup file compatibility with XP

2. Call windows command line (from the Start menu choose Run and print cmd)

3. Move to the directory of the setup.exe file.

4. Print the following: setup.exe -silent


This will start silent installation

Honored Contributor

Re: SM Client on Windows 7 64bit

SM Windows client settings would be stored in 2 folders in Windows 7 box at following location(ramesh.h is my username)






C:\Users\ramesh.h\ServiceManager\workspace\.metada​ta\.plugins\org.eclipse.debug.ui\launchConfigurationHistory file


1st folder name contains all username launch files and 2nd file contains reference to username launch filename.


You need to tweak in both the files and you can see connections in SM windows client and happily connect.


Re: SM Client on Windows 7 64bit

Dear Vadim,


I have tried un installing and reinstalling SM client 9.21 in console mode. but issue is same new connection button is disabled.


Honored Contributor [Founder]

Re: SM Client on Windows 7 64bit

I am not sure whats the problem in your case but you can try to clean iout cache of thye win client.

Respected Contributor

Re: SM Client on Windows 7 64bit

Hi Philip


I have had the same issue. Moving the line see, attached file worked for me.

If you find this post useful/helpful click the Kudo star on this post!

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Trusted Contributor [Founder]

Re: SM Client on Windows 7 64bit

Hi Junaid,

Were you using any previous version of SM client earlier on the same machine?

If yes, then you need to delete files from the Service Manager folder from your User directory.

C:\Documents and Settings\901126\ServiceManager\configuration\org.eclipse.osgi\.manager

C:\Documents and Settings\901126\ServiceManager\configuration\.metadata

Delete all the files from these folders.
I was using SM9.20 client earlier and then upgraded to SM9.21 and again to SM9.30. Was able to solve this issue by deleting the files.
Valued Contributor

Re: SM Client on Windows 7 64bit

Hi there,


I had the same issues as described above.


My solution/workaround:

  1. setupclient.exe -silent
  2. startmeny -> .. -> .. -> Service Manager Client (right click, go to compablity version and change to Window2003sp1)
  3. Start client


Now my Windows2008 R2 x64 Ent with SM9.30.201 client working properly.



Valued Contributor

Re: SM Client on Windows 7 64bit

sorry forgotten that I cleared the cache as well under C:\users..\Service Manager ( del *.*)


Re: SM Client on Windows 7 64bit

hi Sanzz should I re-install SM client? after deleting these files?

new connection Icon is still disabled after deleting these files.

Occasional Visitor

Re: SM Client on Windows 7 64bit

Hey there,

we had this problem, too...

The version which we're using is 9.21.157


I made the installation as a local Admin with the compatibility mode "Winows XP (Service Pack 3)"

After the installation on a Windows 7 Client the configuration menu was empty.


What we have done:
- Repair of installed HPSM Version

- Deletion of the Service Manager folder at C:\User\User-ID

- then i got the hint to change the Screen Resolution



Today i got a hint from a colleague


Start HPSM and then move the line which separates the Connection overview on the left side from the Config Settings on the right side.


See attached files


I hope that was helpful for you


By the way:

If you want to install the Version 9.21.216 on a Win7 - 64 bit Client you have to run the installation as a local Admin with the settings

Compatibility mode is "Windows Vista (SP2)"
Activate the checkmarks "Run in 256 colors" and "Run in 640x480 screen resolution"


kind regards