cancel
Showing results for 
Search instead for 
Did you mean: 

11.16 installation problem

Warren_9
Honored Contributor

11.16 installation problem

Hi,

got the following error when install the SG

# rpm -ivh --nodeps --force serviceguard-A.11.16.01-0.product.redhat.i386.rpm
Preparing... ########################################### [100%]
1:serviceguard ########################################### [100%]
Validating the identd configuration...
Warning: ServiceGuard uses the identd daemon, which does not
appear to be running on this node. Please take the proper
steps to configure and run identd before attempting to
have this node re-join the cluster.

Please change BASEINCLUDE in this Makefile /lib/modules/2.4.21-20.EL/build does not exist
make: *** [chkit] Error 1
Installing under /lib/modules/2.4.21-20.EL/kernel/drivers/char

the directory /lib/modules/2.4.21-20.EL/build does exist, it is the problem on Makefile?
how to change the BASEINCLUDE?
9 REPLIES
Ivajlo Yanakiev
Respected Contributor

Re: 11.16 installation problem

whay you force and nodeps SG.rpm ?
My by you need some add pkg ?
Also you must start/allow your identd demon.
#service identd start
and you must link start script on 2 run level
Do you have /lib/modules/2.4.21-20.EL/build
directory on your system ?
RAC_1
Honored Contributor

Re: 11.16 installation problem

check if xinetd is working or not.
There is no substitute to HARDWORK
Warren_9
Honored Contributor

Re: 11.16 installation problem

hi,

I think the identd is not a must on the SG and it is just a warning.

the problem is in the ".... does not exist.. Error 1", any hint?

to force the install coz the SG rpm needed the 2.4.18 kernel source.

error: Failed dependencies:
kernel-source >= 2.4.18 is needed by serviceguard-A.11.16.01-0

WAR.
Ivajlo Yanakiev
Respected Contributor

Re: 11.16 installation problem

Yes this is your problem !!!
Yopu need kernel source to make /build SG.
SG source links to kernel source you need
KERNEL SOURCE.

Arunvijai_4
Honored Contributor

Re: 11.16 installation problem

Try downloading source rpm for your kernel version and again do the installation.

-Arun
"A ship in the harbor is safe, but that is not what ships are built for"
Serviceguard for Linux
Honored Contributor

Re: 11.16 installation problem

Your DO NOT need to rebuild anything.

You DO NOT need to force anything.

If you try either of these, even if you get the install to work, serviceguard will not work. Admittedly, the error message is a little cryptic. I beleive that part of that is due to how RPM works and may be in part to the fact that you have a force option.

I assume you are doing this with RH3 since that is the RPM you are using.

Either way, you need to uninstall authd and install the version of pidentd that comes with Serviceguard. This part is very well documented in the release notes. These are on the CD.

I'll be monitoring this thread carefully now.
Warren_9
Honored Contributor

Re: 11.16 installation problem

Hi,

I have a search on the RN
http://docs.hp.com/en/B9903-90048/B9903-90048.pdf

But cannot find the "authd".

which document should I reference?

THX,
WAR.
Serviceguard for Linux
Honored Contributor

Re: 11.16 installation problem

Correct document - from page 20:

Installing HP Serviceguard for Linux
The Serviceguard for Linux documentation no longer describes the
process for installing Linux. Please refer to the documentation for this
distribution you are using.
After Linux is correctly configured, installation of HP Serviceguard is
done with the rpm command. Following installation of HP Serviceguard,
the Quorum Server and Serviceguard Manager should be installed.
For any version of Red Hat supported by this release, authd must be
uninstalled. Use the following rpm command:

# rpm -e authd

Use the following commands to install Serviceguard on HP ProLiant
Servers running the 32 bit version of the distributions.
Serviceguard for Linux
Honored Contributor

Re: 11.16 installation problem

One other quick question. When you installed RedHat, did you install the kernel source? That is required for the SG install.