Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot configure SGA.11.15.05 on Linux

J.D._3
Frequent Advisor

Cannot configure SGA.11.15.05 on Linux

Running SG on RedhatAS3upd4. cmcheckconf -v -C runs fine but cmapplyconf -v -C gets error below.

time cmapplyconf -v -C /usr/local/cmcluster/conf/whotdb.conf

Checking cluster file: /usr/local/cmcluster/conf/whotdb.conf
Checking nodes ... Done
Checking existing configuration ... Done
Warning: Can not find configuration for cluster whotdb_cluster
Gathering configuration information ... Done
Gathering configuration information ..
Gathering storage information ..
.
Gathering Network Configuration ......... Done
Checking for inconsistencies .. Done
Maximum configured packages parameter is 5.
Configuring 0 package(s).
5 package(s) can be added to this cluster.
Creating the cluster configuration for cluster whotdb_cluster.
Adding node whotdb1 to cluster whotdb_cluster.
Adding node whotdb2 to cluster whotdb_cluster.
Error: Failed to receive message from configuration daemon on node whotdb2: Connection timed out
Error: Unable to copy file to whotdb2 due to error: Connection timed out
Error: A temporary configuration file ($SGCONF/cmclconfig.tmp) cannot be written to disk on one or more nodes: Connection timed out
Error: Unable to unlock cluster configuration lock on node whotdb2: Unexpected loss of lock detected (configuration lock was lost since last time we locked it).
Error: Unable to apply the configuration change: Connection timed out
. Check the syslog file(s) for additional information.
cmapplyconf : Unable to apply the configuration

real 15m44.927s
user 0m0.020s
sys 0m0.000s

Both systems were rebooted prior to running cmquerycl and cmcheckconf. Node2 was rebooted again today. Has anyone run into this before? Thanks in advance.
5 REPLIES
Luk Vandenbussche
Honored Contributor

Re: Cannot configure SGA.11.15.05 on Linux

Is this a new environment?

Try to obtain al the info with cmquerycl

If it is an existing environment, try with
cmgetconf

Read the man pages for the options
J.D._3
Frequent Advisor

Re: Cannot configure SGA.11.15.05 on Linux

Luk,

This is new environment. cmquerycl works fine. I've updated the ascii file and used it against cmcheckconf. It's cmapplyconf that gets the error above when I try to configure the cluster. Thanks for the reply.

Last night I had an opportunity to reboot both nodes, so I uninstalled the sg and pident rpms, and rebooted the systems. I installed A.11.15.02 and upgraded it to A.11.15.05 and rebooted both boxes. I'm still seeing the issue. Still open for suggestions. Thanks.
Serviceguard for Linux
Honored Contributor

Re: Cannot configure SGA.11.15.05 on Linux

J.D.

Do you have a firewall on? If so, you may want to try turning it off. I can help with the firewall settings tomorrow if that does the trick (it is late here).

If that doesn't help, try creating the cluster from the other node & see if it is different.

Otherwise post the ascii file. And any log files that might have info.

Q: why are you using 11.15 instead of 11.16?

J.D._3
Frequent Advisor

Re: Cannot configure SGA.11.15.05 on Linux

Hi,

There's no firewall between the 2 nodes. What it was is that the sgcmom rpm was not installed and it is apparently needed. The cmapplyconf command works now and both nodes are clustered. I needed A.11.15 because of the oracletoolkit I'm going to be using only is supported until this SG version. Thank you all for your replies. My cluster is now working and online.
Serviceguard for Linux
Honored Contributor

Re: Cannot configure SGA.11.15.05 on Linux

Glad to hear it is working! :)