cancel
Showing results for 
Search instead for 
Did you mean: 

Cmquerycl problem

SOLVED
Go to solution
ANDREA_6
Frequent Advisor

Cmquerycl problem

Hello,
i have a redhat 5 with service guard A 11.18.
I configured correctly /etc/hosts and rlogin works fine between the two cluster nodes.

I anyway experience this problem executing cmquerycl.

I tryed to change /root/.rhosts and cmclnodelist.. but without results.
Do you have any suggestion?

Any help will be appreciated.
Best regards,Andrea.

[root@dtb01 ~]# /usr/local/cmcluster/bin/cmquerycl -C /usr/local/cmcluster/conf/cmcluster.config -n dtb01 -n dtb02
Warning: Unable to determine local domain name for dtb01
Node dtb01 is refusing Serviceguard communication.
Please make sure that the proper security access is configured on node
dtb01 through either file-based access (pre-A.11.16 version) or role-based
access (version A.11.16 or higher) and/or that the host name lookup
on node dtb01 resolves the IP address correctly.
Failed to gather configuration information.

[root@dtb01 ~]# cat /root/.rhosts
+ +

root@dtb01 conf]# pwd
/usr/local/cmcluster/conf
[root@dtb01 conf]# cat cmclnodelist
+ +
10 REPLIES
Ivan Krastev
Honored Contributor

Re: Cmquerycl problem

Make sure that both nodes can resolv each other without problems - add entries in /etc/hosts files.
Also write in you cmclnodelist the following:

node1 root
node2 root


see syntax here - http://docs.hp.com/en/B5158-90024/ch05s01.html

regards,
ivan
ANDREA_6
Frequent Advisor

Re: Cmquerycl problem

Hello,
Thanks for your answer.

Both nodes can resolv each other without problems if i ping them.. nslookup don't works.. is it normal on linux if i don't use a dns?
Matti_Kurkela
Honored Contributor

Re: Cmquerycl problem

Yes, RedHat's default nslookup only queries DNS servers, no matter how /etc/nsswitch.conf is configured. So it is normal.

MK
MK
ANDREA_6
Frequent Advisor

Re: Cmquerycl problem

Hello,
i checked my cmclnodelist, my rhosts, /etc/hosts,/etc/hosts.equiv but i continue to get the previous error running cmquerycl.
Any idea?
Serviceguard for Linux
Honored Contributor
Solution

Re: Cmquerycl problem

Typically, this is one of a number of problems.

1. Usually this means that the firewall is set up incorrectly. Try turning off the firewall

2. Also, identd may not have started. "identd" is the service associated with pidentd (see #2). Make sure this is set to start automatically.

3. Also, xinetd may not be started, or set to start automatically. "/sbin/chkconfig --level 345 xinetd on" will make sure it is on after reboot. And "/etc/init.d/xinetd restart" will start it immediately.

4. Check that the file cmclnodelist has been created and is set up correctly.

After you make all of the changes, reboot both nodes.
ANDREA_6
Frequent Advisor

Re: Cmquerycl problem

Thanks,
I executed this checks.
Xinetd and identd are configured to to start automatically and firewall is disabled.

I did many test with cmclnodelist but without results.

Is there something else to check?

[root@dtb01 init.d]# chkconfig --list xinetd
xinetd 0:off 1:off 2:off 3:on 4:on 5:on 6:off
[root@dtb01 init.d]# chkconfig --list identd
identd 0:off 1:off 2:off 3:off 4:off 5:on 6:off
[root@dtb01 init.d]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


Best regards,Andrea.
Ivan Krastev
Honored Contributor

Re: Cmquerycl problem

What is your runlevel? identd is configured only for runlevel 5.

regards,
ivan
ANDREA_6
Frequent Advisor

Re: Cmquerycl problem

Hello,
My runlevel is 5:

[root@dtb01 conf]# runlevel
N 5

Best regards,Andrea.
Ivan Krastev
Honored Contributor

Re: Cmquerycl problem

Try to increase debug levels of SG or run some checks - network restrictions (firewalls), permissions ...

regards,
ivan
Serviceguard for Linux
Honored Contributor

Re: Cmquerycl problem

Try the following on ntb01:

# /usr/local/cmcluster/bin/cmquerycl -v -w full -C /usr/local/cmcluster/conf/cmcluster.config -n dtb01 -n dtb02

# /usr/local/cmcluster/bin/cmquerycl -v -w full -C /usr/local/cmcluster/conf/cmcluster.config -n dtb01

Then try on ntb02:

# /usr/local/cmcluster/bin/cmquerycl -v -w full -C /usr/local/cmcluster/conf/cmcluster.config -n dtb01 -n dtb02

# /usr/local/cmcluster/bin/cmquerycl -v -w full -C /usr/local/cmcluster/conf/cmcluster.config -n dtb02

Look in syslog and see of there are any messages around the time of the cmquerycl command.

Finally, are you aware of the installation scripts? http://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=SGLXICS


Also - send a copy of the /etc/hosts file and /etc/nsswitch.conf