Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

How to setup locklun on server running multipath?

Linus_1
Occasional Visitor

How to setup locklun on server running multipath?

I have a problem whit a service guard cluster..

We have moved all the LUN's the cluster use to a SAN that supports multipath.. so it's now totaly 48 sda, sdaa and so on..

earlier I had 6 devices in /dev sda-sdf
each device was a lun and the lock lun was sdb1

When we moved to the new SAN all the LUN's got 8 devices each..

I have tryed to set the lock lun to /dev/dm-2 or /dev/mpath/mpath2 which is the lun we want to use but when I check t he conf I got an error that says this:

Error: /dev/dm-2 is not a valid device. Validation failed.
Error: Invalid data for cluster lock LUN configuration
cmcheckconf : Unable to verify cluster file: /usr/local/cmcluster/conf/cluster1.ascii

4 REPLIES
Linus_1
Occasional Visitor

Re: How to setup locklun on server running multipath?

I maybe should have used the search function first, I found that serviceguard cluster cant use mpath or dm* devices for locklun..

Is there any way for me to solve this so I can get the cluster working??
Kevin Wright
Honored Contributor

Re: How to setup locklun on server running multipath?

yes, use a device such as /dev/sda. remove md for your lock.
Linus_1
Occasional Visitor

Re: How to setup locklun on server running multipath?

Can you explain what you mean whit "remove md for your lock" ?

the lun that I want to use for lock is whown as
eight devices:

mpath2 (3600508b4000556f20000800003f30000)
[size=1 GB][features="1 queue_if_no_path"][hwhandler="0"]
\_ round-robin 0 [prio=200][active]
\_ 1:0:2:3 sdam 66:96 [active][ready]
\_ 1:0:3:3 sdas 66:192 [active][ready]
\_ 0:0:2:3 sdo 8:224 [active][ready]
\_ 0:0:3:3 sdu 65:64 [active][ready]
\_ round-robin 0 [prio=40][enabled]
\_ 1:0:0:3 sdaa 65:160 [active][ready]
\_ 1:0:1:3 sdag 66:0 [active][ready]
\_ 0:0:0:3 sdc 8:32 [active][ready]
\_ 0:0:1:3 sdi 8:128 [active][ready]
Linus_1
Occasional Visitor

Re: How to setup locklun on server running multipath?

I solved it, installed qlogic drivers and it works fine..