Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

Node is refusing Serviceguard communication

SOLVED
Go to solution
George Denyer_1
Frequent Advisor

Node is refusing Serviceguard communication

Hello,

I am yet another victim of this error message: "Node XYZ is refusing Serviceguard communication".

I am setting up a cluster consisting of two nodes running RedHat EL 5 and ServiceGuard A.11.18. The cluster hasnt been created yet, I'm trying to run cmquerycl for the first time and I get this message:

[root@cafsa1 conf]# cmquerycl -v -C $SGCONF/cafsa.conf -n cafsa1
Warning: Unable to determine local domain name for cafsa1
Looking for other clusters ... Done
Node cafsa1 is refusing Serviceguard communication.
Please make sure that the proper security access is configured on node
cafsa1 through either file-based access (pre-A.11.16 version) or role-based
access (version A.11.16 or higher) and/or that the host name lookup
on node cafsa1 resolves the IP address correctly.
Failed to gather configuration information.
[root@cafsa1 conf]#

After reading the docs and the many posts on this forum related to similar problems I have made sure the firewall is disabled, identd is running, cmclnodelist lists the node with user root (I also tried with "+"), the hosts file lists the node correctly, and just in case /root/.rhosts also lists the node with user root; and yet, I keep getting the same error message.

I seem to have ran out of ideas, so if anybody has something to suggest, I'll appreciate it.


4 REPLIES
John Bigg
Esteemed Contributor
Solution

Re: Node is refusing Serviceguard communication

Make sure that all IP addresses on the system resolve to the hostname. SG should allow aliases also but the 11.18 base code does not. You will need a patch for that.

Check that xinetd is running. Is it even installed? rpm -q xinetd I believe that RH5 may not install it by default and if it's not running you will get the symptom you see. Can you telnet localhost on port 5302? i.e.

telnet localhost 5302

If not this indicates an xinetd/SG cmclconfd problem and although it does not test the UDP connection which looks like it could be broken this will at least show you if things are fundamentally broken.

Future rpms will have a dependency on the xinetd rpm.

If all this checks out then post your syslog file.
George Denyer_1
Frequent Advisor

Re: Node is refusing Serviceguard communication

Hello John, thanks for your answer.

All IP addresses on the system do resolve to the hostname, without aliases; but I'm pretty sure xinetd is not installed, if it's a requirement that's probably it.

I'll install it today and test. Thanks.
Steven E. Protter
Exalted Contributor

Re: Node is refusing Serviceguard communication

Shalom,

Serviceguard uses xinetd to run a couple of daemons. If its been commented out or not installed, this will need to be corrected before moving forward.

The install should have squawked about this however.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
George Denyer_1
Frequent Advisor

Re: Node is refusing Serviceguard communication

Hello all,

I installed xinetd, as John suggested, and the error is gone.

Apparently xinetd is not installed by default in RHEL5, SG doesnt verify if it is installled, and the docs dont mention it as a requirement.

Thanks to John and Steven.

G. Denyer