HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

Package doesn't switch after ifdown interface

 
AWFM_GMS_SUPPORT_SYSTEM
Occasional Advisor

Package doesn't switch after ifdown interface

Hello All,

I configured Serviceguard 11.18-05 on 2 proliant DL380 G5 in Rhel5.2. I monitored 2 subnet (172.19.32.192 et 172.19.33.0) associated respectively to eth0 and eth2(without bonding). When I simulated a failure on one of these interfaces on primary node, package fall in failed but doesn't switch on secondary node. To start the package I need to do cmmodpkg -e on secondary node and the node failed doesn't reboot too.
Thank you for your help.

Willy
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: Package doesn't switch after ifdown interface

Shalom,

Please post here or look at the logs when you run this test.

/var/log/messages is the standard RHEL log, though Service Guard may use its own log file.

It is not clear to me if you are disconnecting the public IP interface of the system or the heartbeat network.

If you disconnect heartbeat and have to networks configured for heartbeat on the system then failure may not be triggered due to redundant heartbeat network.

It would also help to see the package control script. It may be configured incorrectly.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
AWFM_GMS_SUPPORT_SYSTEM
Occasional Advisor

Re: Package doesn't switch after ifdown interface

Hello Steve,

Thank you for you reply, I put all logs (Rhel and serviceguard) during the test and all actions done and configuration files of cluster.

Willy
AWFM_GMS_SUPPORT_SYSTEM
Occasional Advisor

Re: Package doesn't switch after ifdown interface

Hello All,

I uploaded all logs about /var/log/mesages, serviceguard and all actions I did about this test.
By looking in serviceguard log it seems the problem appeared because when I issued ifdown eth0, all aliases associated at this device are down too but despite this serviceguard tries to remove these aliases and as the remove is failed serviceguard set the package in "failed unowned".
For information all other cluster tests (crash, reboot,lost SAN links ...) are OK.

Thank you for your help.

Willy
smatador
Honored Contributor

Re: Package doesn't switch after ifdown interface

Hi,
Perhaps, you have an issue with the configuration file specialy with the monitored_subnet

If I understand the doc, when you use monitored_subnet is to be monitored for a package.
If you specify a subnet as a monitored_subnet the package will not run on any node not reachable via that subnet. This normally means that if the subnet is not up, the package will not run. cf p217 of the
Managing HP Serviceguard for Linux, Eighth Edition

When you do ifdown of a monitored_subnet, you disable normally the access of the subnet. So perhaps, it explain what happen. When you cmmodpkg -e, you enable it on the second node?
AWFM_GMS_SUPPORT_SYSTEM
Occasional Advisor

Re: Package doesn't switch after ifdown interface

Hi Smatador,

Thank you for your reply, in fact in the serviceguard template (11.18-05 for Rhel5.2) there are 2 parameters MONITORED_SUBNET (subnet monitored for package ) and MONITORED_SUBNET_ACCESS (access to MONITORED_SUBNET configured on all node) but according documentation this last parameter with option "FULL" is equal to MONITORED_SUBNET.
I opened a case at HP, I hope they would give me a solution to fix this problem.

Regards,

Willy
AWFM_GMS_SUPPORT_SYSTEM
Occasional Advisor

Re: Package doesn't switch after ifdown interface

Hi All,

HP gave me an explanation about the failed of package when I issued an ifdown on a network device, the test with this command is not a valid test with Serviceguard on Linux.
To test failover of network you must remove network cable behind server or set disable newtork port on switch.
I chose the last possibility and Serviceguard works well.

Regards,

Willy