Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem creating ServiceGuard cluster with Linux

Ed Kwan_2
Advisor

Problem creating ServiceGuard cluster with Linux

Hi,
I am trying to create a two node cluster with lock lun. cmquerycl and cmapplyconf both works, but when I try to start the cluster, logfile shows:

cmlocklund: error setting raw device (Invalid argument)
cmlocklunk: error binding block device (dev/sda1) to a char device.

I have changed the /dev/sda1 to a character device but still report the same problem. I therefore changed it back to a block device.

Any help is appreciated.

Thanks, Ed
14 REPLIES
melvyn burnard
Honored Contributor

Re: Problem creating ServiceGuard cluster with Linux

please post your cluster ascii file here.
Also what discs are you using? what OS? what version of SG for Linux?
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Ed Kwan_2
Advisor

Re: Problem creating ServiceGuard cluster with Linux

Configuration file:

CLUSTER_NAME atre


NODE_NAME XHQSMYDB01
NETWORK_INTERFACE bond0
HEARTBEAT_IP 10.192.228.161
NETWORK_INTERFACE eth0
HEARTBEAT_IP 11.11.11.10
CLUSTER_LOCK_LUN /dev/sda1

# Channel Bond bond0 contains the following port(s): eth2
# Warning: There are no standby network interfaces for bond0.
# Warning: There are no standby network interfaces for eth0.

NODE_NAME XHQSMYDB02
NETWORK_INTERFACE bond0
HEARTBEAT_IP 10.192.228.184
NETWORK_INTERFACE eth0
HEARTBEAT_IP 11.11.11.11
CLUSTER_LOCK_LUN /dev/sda1

# Channel Bond bond0 contains the following port(s): eth2
# Warning: There are no standby network interfaces for bond0.
# Warning: There are no standby network interfaces for eth0.


HEARTBEAT_INTERVAL 1000000
NODE_TIMEOUT 6000000


# Configuration/Reconfiguration Timing Parameters (microseconds).

AUTO_START_TIMEOUT 600000000
NETWORK_POLLING_INTERVAL 2000000

We have installed 11.15 serviceguard and RedHat AS 3.0 on DL 585 boxes.

Lock disk is suppose to be /dev/sda1 which has type id of 83 (Linux) per documentation.

Thanks, Ed
JohnWRuffo
Honored Contributor

Re: Problem creating ServiceGuard cluster with Linux

Ed:
Check out this post for the Service Guard Moderator:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=665900
Enjoy!
__________________________________________
Was the post useful? Click on the white KUDOS! Star.

Do you need help with your HP product?
Try this: http://www.hp.com/support/hpgt
Serviceguard for Linux
Honored Contributor

Re: Problem creating ServiceGuard cluster with Linux

Can you add information about your hardware configuration, especially your shared storage.

Thanks

Re: Problem creating ServiceGuard cluster with Linux

Hi Ed,

I have got the same issue like you with MC Service Guard A.11.15 with Linux Redhat AS 3.0 SMP.

I have got some servers HP Proliant DL360 connected to a MSA 1000 disk array.

Did you solve your problem ? If yes what is the solution ?

Thanks,

Rick.
Serviceguard for Linux
Honored Contributor

Re: Problem creating ServiceGuard cluster with Linux

The LUN should have no file system - just be raw. If there was a file system on there, you need to wipe it out. I think that running a command similar to dd if=/dev/zero of-/dev/sda1 count=1 bs=512 (double check the block size) will work - but you may want to look around and check that this is the most appropriate way.

One other point to be aware of: The MSA1000 is active/passive. That is, when one array processor is active the other is not. All servers in the cluster need to have access to the LUN when LOCK_LUN is used. If your storage configuration doesn't match the recommended (2 HBAs, 2 Swtiches, 2 controllers in the MSA1000,
multipath turned on in the QLogic driver) then you may want to force a check (use writes not just reads).

By the way, the configuration as described in the manuals and elsewhere is the supported configuration.

Re: Problem creating ServiceGuard cluster with Linux

Hi thanks for your answer.

I have defined /dev/sda1 for my lock lun.
It is partitionned like that :

[root@mar-clu-bdd-01 root]# fdisk -l /dev/sda

Disk /dev/sda: 53.6 GB, 53686272000 bytes
255 heads, 63 sectors/track, 6526 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 1 1 8001 83 Linux
/dev/sda2 2 2 8032+ 83 Linux

I have used before this device to create an ext2 fs. I will do the dd now.
Do you think that Secure Path 3.0C is necessary to insure the FCA2214DC fc cards to switch in case of failure ?

I have got 2 proliant conected to the MSA 1000. Each Proliant as a FCA2214DC card (double q logic fc card QLA2342).

I have give you the feedback for the cmlockkund issue.

Re: Problem creating ServiceGuard cluster with Linux

Hi,

I still have the cmlocklund errors :

cmlocklund: error setting raw device (Invalid argument)
cmlocklunk: error binding block device (dev/sda1) to a char device.

Do you have any others suggestions ?

I join my ascii file. Will check the configurations as you siad tomorrow.

Rick.
Serviceguard for Linux
Honored Contributor

Re: Problem creating ServiceGuard cluster with Linux

I don't see any problem with the configuration file.

I'd recommend using the multipath feature built into the QLogic driver. I don't have all of the details but if you download the latest driver, I think the documentation will be part of the download.

I'll check with one of the other engineers tomorrow to see if he knows that error.

Definately do not change the charateristics of the lock lun device.

One other thing I can think of you trying if you can. If you can create a new LUN on the array - and then create the lock lun parition on it just as described in the "setting up Lock LUN section of the "Managing" manual.

Remember, no filesystems on this LUN.

Remember the sfdisk commands to ensure that the partition information matches. Try forming and starting the cluster with this new LUN. That would determine if the problem is related to the existing LUN you are using or if it is some other problem.

Serviceguard for Linux
Honored Contributor

Re: Problem creating ServiceGuard cluster with Linux

Try limiting the cluster name to 8 characters.
Serviceguard for Linux
Honored Contributor

Re: Problem creating ServiceGuard cluster with Linux

I actually meant limit the node name to 8 characters. You might want to try limiting all names to 8 characters and I can find out which is critical.

Re: Problem creating ServiceGuard cluster with Linux

Hi,

I have changed the nodes' name to 8 characters.
Still have the problem. I have an kernel ioctl error message with the two primary ones :

Apr 27 10:52:59 clubdd01 kernel: ioctl32(cmlocklund:3936): Unknown cmd fd(5) cmd(0000ac01){00} arg(ffffa530) on /dev/rawctl
Apr 27 10:52:59 clubdd01 cmlocklund[3949]: Port number returned by locklund_setup: 32881
Apr 27 10:52:59 clubdd01 cmcld: Lock LUN resumed (port = 32881).
Apr 27 10:52:59 clubdd01 cmlocklund[3949]: Error setting raw device (Invalid argument)
Apr 27 10:52:59 clubdd01 cmlocklund[3949]: Error binding block device (/dev/sda1) to a char device.
Apr 27 10:52:59 clubdd01 cmcld: Service cmlocklund terminated due to an exit(1).
Apr 27 10:52:59 clubdd01 cmlocklund[3952]: Total allocated: 540672 bytes, used: 0 bytes, unused 540672 bytes
Apr 27 10:53:00 clubdd01 cmcld: Automatically restarted service cmlocklund for the 11th time after failure.

I have got this version of the QLogic drivers : hp_qla2x00src-7.05.00-9.

I will check the failover status ...
melvyn burnard
Honored Contributor

Re: Problem creating ServiceGuard cluster with Linux

If this also fails, I strongly recommend you log a support call with your local HP Response Centre.
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!

Re: Problem creating ServiceGuard cluster with Linux

i all,

We had a 64-bit version of Redhat AS 3.0 (uptdate 3) for AMD64 and Intel EM64T installed on our HP Proliant DL 360 servers with HP MC Service Guard (i386 version).

We have installed the 32-bit version of Redhat AS 3.0 (update 4) and we are able now to start our cluster.

Thanks to all for helping me.

Regards,

Eric.