HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem when installing creating package

 
SOLVED
Go to solution
KOUYATE MAURY
Frequent Advisor

Problem when installing creating package

Hi,
I have successfully configure my cluster with serviguard, now i wanted to create a package. After editing my Package Configuration Template File and the Package Control Script, when trying to Verify the Package Configuration i received this error message:
:/opt/cmcluster/bin # ./cmcheckconf -k -v -p /opt/cmcluster/conf/orapkg/orapkg.config
usage: cmcheckconf [-v] [-C cluster_ascii_file]
[[-p pkg_reference_file] | [-P pkg_ascii_file...]]

Now when i try to change the command i got this:
oraserv1:/opt/cmcluster/bin # ./cmcheckconf -v -k -C /opt/cmcluster/conf/orapkg/orapkg.config

Checking cluster file: /opt/cmcluster/conf/orapkg/orapkg.config
Error: Unknown keyword (PACKAGE_NAME) on line 13
Refer to documentation for valid keywords and identifiers.
cmcheckconf : Error found in cluster file: /opt/cmcluster/conf/orapkg/orapkg.config

when i try an other one i received this:

oraserv1:/opt/cmcluster/bin # ./cmcheckconf -v -p /opt/cmcluster/conf/orapkg/orapkg.config

Checking existing configuration ... Done
Gathering configuration information ... Done
"-p" option specified. Opening package reference file: /opt/cmcluster/conf/orapkg/orapkg.config.
Parsing package file: PACKAGE_NAME orapkg .

cmcheckconf : Nonexistent package ascii file: PACKAGE_NAME orapkg .



So i don't know what is missing.
in fact i wanted to run an application on oracle so i want to create one package witch will start, stop oracle and the application.

Best regards

Kouyate Maury
4 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: Problem when installing creating package

Shalom Kouyate,

The first problem I see from my extremely basic SG knowledge is a possible mistake on the approach.

Perhaps it would be best to take a minimalist approach to actually creating the package.

Assuming hte package does not already exist the textbook approach:

cmhaltcl
cmmakepkg -p packagename.ascii
# make necessary editing changes.
cmmakepkg -s packagename.sh
# make necessary editing changes again.

cmcheckconf -P packagename.ascii
cmapplyconf -P packaagename.ascii

You know the desire results.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
melvyn burnard
Honored Contributor

Re: Problem when installing creating package

Well you are using the incorrect options with the cmcheckconf.
if you do man cmcheckconf you will find you need to use the -P option to tell it you wish to use a package config file.

I also advise you read the Managing Serviceguard manual available at http://docs.hp.com/en/ha

And possibly sign up for a training course with your HP Customer Education centre
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
KOUYATE MAURY
Frequent Advisor

Re: Problem when installing creating package

Hi, thanks for your help as u can see my package is created but the pachage is down. i've try to create a new one but same result this is the status:CLUSTER STATUScluster up NODE STATUS STATE oraserv1 up running Cluster_Lock_LUN: DEVICE STATUS /dev/cciss/c1d0p1 up Network_Parameters: INTERFACE STATUS NAME PRIMARY up eth0 PRIMARY up eth1 NODE STATUS STATE oraserv2 up running Cluster_Lock_LUN: DEVICE STATUS /dev/cciss/c1d0p1 up Network_Parameters: INTERFACE STATUS NAME PRIMARY up eth0 PRIMARY up eth1UNOWNED_PACKAGES PACKAGE STATUS STATE AUTO_RUN NODE oraclepkg down halted disabled unowned Policy_Parameters: POLICY_NAME CONFIGURED_VALUE Failover configured_node Failback manual Script_Parameters: ITEM STATUS NODE_NAME NAME Subnet up oraserv1 213.172.128.0 Subnet up oraserv2 213.172.128.0 Node_Switching_Parameters: NODE_TYPE STATUS SWITCHING NAME Primary up enabled oraserv1 Alternate up enabled oraserv2 PACKAGE STATUS STATE AUTO_RUN NODE orapkg down halted disabled unowned Policy_Parameters: POLICY_NAME CONFIGURED_VALUE Failover configured_node Failback manual Script_Parameters: ITEM STATUS NODE_NAME NAME Subnet up oraserv1 213.172.128.0 Subnet up oraserv2 213.172.128.0 Node_Switching_Parameters: NODE_TYPE STATUS SWITCHING NAME Primary up enabled oraserv1 Alternate up enabled oraserv2oraserv1:/opt/cmcluster/bin # cmrunpkg -n oraserv1 orapkgcmrunpkg : Script failed with no restart: orapkg should not be restarted.Check the syslog on node oraserv1 and pkg log files for more detailed information.oraserv1:/opt/cmcluster/bin # cmrunpkg -n oraserv2 orapkgcmrunpkg : Script failed with no restart: orapkg should not be restarted.Check the syslog on node oraserv2 and pkg log files for more detailed information.This is the error in the log file:/opt/cmcluster/conf/orapkg/control.sh: line 149: rw: command not found###### Node "oraserv1": Starting package at Wed Dec 28 12:16:52 PST 2005 ######Dec 28 12:16:52 - Node "oraserv1": Starting md /dev/cciss/c1d1p2 .detected error on line 27: id = "CLje5W-2mYp-Q93y-Fat3-e5e0-xhoj-UNvBtB"ERROR: Function activate_md; Failed to activate /dev/cciss/c1d1p2Dec 28 12:16:52 - Node "oraserv1": Deactivating md /dev/cciss/c1d1p2usage: raidstop [--all] [--configfile] [--help] [--version] [-achv] *ERROR: Function deactivate_md; Failed to deactivate /dev/cciss/c1d1p2###### Node "oraserv1": Package start FAILED at Wed Dec 28 12:16:52 PST 2005 ######Best regards
KOUYATE MAURY
Frequent Advisor

Re: Problem when installing creating package

I’ve Edith the package control script with basic information like nodes name and ip address and left the others with the default, the package start. And gradually add the others information’s by testing the package start-up at each step.
Thanks