HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with RHAS3 Update4 and ServiceGuard 11.16.01

 
Nuno Silva
Occasional Visitor

Problem with RHAS3 Update4 and ServiceGuard 11.16.01

When run cmquerycl to generate a template for the cluster
I have this error messages

cmquerycl -v -L /dev/cciss/c1d1p1 -n hgsaora01 -n hgsaora02 -C $SGCONF/hgsaora.config

Begin checking the nodes...
Looking for other clusters ... Done
Gathering configuration information ..
Gathering storage information ..
.....
Gathering Network Configuration ..... Done
Error: Error 103 (Software caused connection abort) performing security validation. Please verify that identd is running properly.
Error: Unable to connect to node hgsaora01: Software caused connection abort
Error: Error 103 (Software caused connection abort) performing security validation. Please verify that identd is running properly.
Error: Unable to connect to node hgsaora02: Software caused connection abort
Warning: Not probing node hgsaora01 as it is currently unreachable.
This may cause network partitions to be reported.
Warning: Not probing node hgsaora02 as it is currently unreachable.
This may cause network partitions to be reported.
Failed to gather configuration information.
3 REPLIES
Steven E. Protter
Exalted Contributor

Re: Problem with RHAS3 Update4 and ServiceGuard 11.16.01

rpm -q

Is it installed properly?

Did you upgrade the OS without waiting for HP to certify SG with the OS? Not a good idea.

What looks to be happening here is a simple problem with network configuration:

1) See that the hardware is working right. Start with ifconfig and see if the nic can ping itself, then others.

2) Check cabling and network hardware. Make sure its all on and working.

3) Check other hardware/nic's on the same subnet. ping, ifconfig, etc.

4) Check the serviceguard confiuration and look for errors, typos or inconsistent network configuration in the failover configuration.

Was it working ever on RH 3 update 4?

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Serviceguard for Linux
Honored Contributor

Re: Problem with RHAS3 Update4 and ServiceGuard 11.16.01

Here are two things to try.

First, you may not have installed PIDENTD correctly. As noted in anotehr posting, authd needs to be removed first (rmp -e authd) before installing pidentd. The first couple of errors sound like they are related to thi.

Try turning off the firewall. The second set of errors sound like it may be a firewall problem. After you get the cluster up, you can get the rest of the firewall settings corrected.
melvyn burnard
Honored Contributor

Re: Problem with RHAS3 Update4 and ServiceGuard 11.16.01

You may wish to review these documents:

http://docs.hp.com/en/B9903-90042/B9903-90042.pdf

http://docs.hp.com/en/5874/securingserviceguard.pdf

http://docs.hp.com/en/6277/SGsecurityfiles.pdf


My house is the bank's, my money the wife's, But my opinions belong to me, not HP!