Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

RedHat AS 2.1 + ServiceGuard problem + cluster not start

 
Laszlo Csizmadia
Frequent Advisor

RedHat AS 2.1 + ServiceGuard problem + cluster not start

I have RH AS 2.1 + MC/SG and a little problem.
[root@cluster1 root]# /etc/init.d/cmcluster.init start
1 XML error(s) found
tcp 0 0 0.0.0.0:5302 0.0.0.0:* LISTEN
udp 0 0 0.0.0.0:5302 0.0.0.0:*
cmrunnode : Unable to determine the nodes on the current cluster
cmrunnode : Either no cluster configuration file exists, or the file is corrupted, or cmclconfd is unable to run
Local node is not currently configured in a cluster
ERROR: Unable to join cluster

This is due to:
[root@cluster1 root]# /usr/local/cmcluster/bin/cmresmond --start
1 XML error(s) found
[root@cluster1 root]# ll /usr/local/cmcluster/conf/cmresmond_config.xml
-rw-r--r-- 1 root root 0 Dec 11 11:20

What should be in this xml config file? I didn't find any docs for this.

I will appreciate any help.
Thanks in advance.
5 REPLIES

Re: RedHat AS 2.1 + ServiceGuard problem + cluster not start

this file contains parameters used by SG cmresmond service to monitor disks, services

these are exemple in /opt/cmcluster/conf/schemas

If you don't use it, you should disable those services in the cluster and package config files.

Regards
Denis
Laszlo Csizmadia
Frequent Advisor

Re: RedHat AS 2.1 + ServiceGuard problem + cluster not start

Denis,

I guess you mean /usr/local/cmcluster/conf/schemas. I can't really use these files:
[root@cluster1 root]# ll /usr/local/cmcluster/conf/schemas
total 12
-r--r--r-- 1 root root 1870 Dec 17 2002 ResMonConfigTypes.xsd
-r--r--r-- 1 root root 2904 Dec 17 2002 ResMonServerConfig.xsd
-r--r--r-- 1 root root 2820 Dec 17 2002 ResMonTypes.xsd

I guess these config files should be generated with cmconfigres create command.
When it fails give me this:
Failed running /usr/local/cmcluster/bin/cmviewcl -l package
Let's see:
[root@cluster1 root]# /usr/local/cmcluster/bin/cmviewcl -l package
cmviewcl : Cannot view the cluster configuration. Either this node is not configured in a cluster, or else there is some obstacle to viewing the configuration. Check the syslog file for more information. For a list of possible causes, see the ServiceGuard manual for cmviewcl.

And I'm not able to create the cluster config:
[root@cluster1 root]# cmquerycl -v -C /usr/local/cmcluster/conf/apache.config -n cluster1 -n cluster2 -q quorum

Begin checking the nodes...
Looking for other clusters ... Done
Error: Unable to establish communication to node cluster2: 19
Failed to gather configuration information.

Did anybody succeded to start MC/SG on RH AS 2.1?
Is this a bug or I totaly misunderstand the concept?
Steven E. Protter
Exalted Contributor

Re: RedHat AS 2.1 + ServiceGuard problem + cluster not start

Believe it or not the default configuration of iptables and ipchains firewall can interfere with serviceguard.

service iptables stop on both machines and try again.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Quint
Occasional Visitor

Re: RedHat AS 2.1 + ServiceGuard problem + cluster not start

I have the same problem as those mentioned above, removed any & all association with firewall... so that is not the prob.
Anyone able to get this software to run.
Any help is greatly appreciated....
Thanks
Serviceguard for Linux
Honored Contributor

Re: RedHat AS 2.1 + ServiceGuard problem + cluster not start

One of the most common problems when the cluster cannot form (and one node cannot talk to another) is the use of the wrong network driver. Look carefully at the readme and use the driver listed there.