cancel
Showing results for 
Search instead for 
Did you mean: 

SG Cluster/Oracle toolkit

SOLVED
Go to solution
Muhammad Shamroze
Frequent Advisor

SG Cluster/Oracle toolkit

One of our customer I installed Service Guard Cluster on two node machine
and shared storage is MSA500-G2. Complete detail is as follows

1.HP Proliant DL-580 and the other node is DL-380
2.Shared storage is MSA500-G2
3.Service Guard for Linux release A.11.16
4.HP SG for Linux Oracle toolkit
5.Red Hat AS-4.0
6.Oracle 9i
7.Single instance database on Shared Storage.
8.Also Oracle installed in shared storage.
9.On shared storage all partitions configured under volume group.
10.Kernel version is 2.6.9-5.ELsmp

We have created cluster on dual node and checked according to the documentation and it is working fine.But when we are doing package
configuration for Oracle database startup/shutdown according to the README
file which came along with the toolkit cd we faced problem.
We are doing Single instance
configuration,Oracle binaries,executables and
database resides on shared storage and from both the node one by one we
brought up the oracle database successfully. But when we configured the
"haoracle.conf" file and run through a script which is called
"haoracle_sql.sh" file giving error.which is as follows "line 133:return:can
only 'return' from a function or sourced script.We checked this on web and
we replaced "return" code with "exit" code this change solve this issue.We
executed this script again and found new error "sqlplus/bin not found
libraries libclntsh.so.9.0". Again we change in script and add "sudo" with
su - ${ORACLE_ADMIN}.Executed script and found no errors but also found no
processes of Oracle instance.One thing more we are running this script from
oracle user where all enviornements already configured.Pleaase tell me how
we can resolve our issue or you can send any thorough documentation for this
configuration or tips.I will be very thanks full for your help.
8 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: SG Cluster/Oracle toolkit

Shalom,

I suggest putting the full path to the sqlplus binary to resolve the second problem.

It would appear that this is caused by the environment for oracle not being right.

My general plan for starting and stopping oracle involes the su - oracl -c "command to start oracle" method

The error is indicative of an environment error.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Serviceguard for Linux
Honored Contributor

Re: SG Cluster/Oracle toolkit

Another point - you must use Update 1 or later for RedHat EL4 (see the certification matrix on the page http://www.hp.com/info/sglx ). The starting kernel is 2.6.9-11. This may not be related to your current problem, but it could cause you problems later.
Muhammad Shamroze
Frequent Advisor

Re: SG Cluster/Oracle toolkit

Hye ALL,Thanks for replying well as i have solved my problem by putting all the enviroments in the following scripts that is "haoracle_sql.sh" and my linux was same no update one installed and kernel version was also same...as i also remove all the curly brackets in the enviroment variable for example ..if the scripts is 'su - ${ORACLE_ADMIN}' and remove the curly brackets which make the scripts 'su - $ORACLE_ADMIN. and also define envirment in the scripts that is 'ORACLE_ADMIN= oracle'
export ORACLE_ADMIN. and also replaced "return" code with "exit" code...and now the package is formed and working fine but i want to know why we have change this is scripts "haoracle_sql.sh" as in the readme we only need to edit one script that is "haoracle.conf" so is this all we have to while running this scripts..what should be done that ...there is no need of editing "haoracle_sql.sh" and just edit the scripts "haoracle.conf" and make pakage and apply the script on package ...please reply on this and also one question more that as this package and clustering is working fine ...but what problem should be occur as we havent installed Linux AS-4.0 update1 and nore the Kernel version 2.6.9-11...kindly reply me so ill be thankful...waiting for ur reply
Steven E. Protter
Exalted Contributor

Re: SG Cluster/Oracle toolkit

Shalom again Muhamad,

You have a very low ratio of point assignments.

If these nice people helped the, please thank them with points in addition to words.

:-)

Peace!

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Muhammad Shamroze
Frequent Advisor

Re: SG Cluster/Oracle toolkit

I have assinged points but u didnt reply about my last answer kindly reply me about my last reply so ill be thankful....
melvyn burnard
Honored Contributor

Re: SG Cluster/Oracle toolkit

...but what problem should be occur as we havent installed Linux AS-4.0 update1 and nore the Kernel version 2.6.9-11...

Well anything might happen, as this has not been tested!.
Also, if you log a call with HP you will told this is unsupported, and you need to apply the update and then see if you have the same issue.
Personally I have installed the Oracle Toolkit on a number of Oracle SG/Linux clusters and have had no problems. I certainly have not had to do the type of changes you have documented.
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Serviceguard for Linux
Honored Contributor

Re: SG Cluster/Oracle toolkit

First let me emphasize what Melvyn said - there is no support unless you are running the correct kernel versions.

To answer your question on the problem found in testing:

I can't be very specific since the testing was done so long ago. There was a problem where, because of something in the Kernel, Serviceguard would not operate correctly in some failure conditions. You would not likely see it in what you have done to date. You might not even see it if you try some failover tests. But it is not a good idea operating an HA product in an environment where it will not protect you as you might expect.

Once we found this, and then found out that it was fixed in Update 1, we didn't do much more testing with the base version. That means that could be more problems that just that one.

Regards
Muhammad Shamroze
Frequent Advisor

Re: SG Cluster/Oracle toolkit

Hello ALL, Well as i told u that the cluster was running fine and package is also running fine...today i halt the package and also halt the cluster..and installed application server on different node...As only database server is on cluster b/w two node and application is on different node with no cluster but integerate with the cluster node..as havent change the cluster and package configuration they were the same but when application server installed the oracle application...i again start the cluster services from live server node it successfully formed the cluster but umount the Volume Group and also deactivate the VolumeGroup that is /oradb where oracle database is i mean the where the Package reside..why this is happening..as i only installed the application server on different node which is integerating with the database cluster node..and havent also change any package and cluster configuration file..when i run the command cmruncl -v it umount the VG and also deactivate it from Current Cluster node but i can see this VG on the Failover node..why this is happening?

after this problem what i did that after running the cluster i again activated the VG by "vgvhange -a y" and mount the VG on current cluster node and run the command cmmodpkg -e Pkg-name and it formed the package and database is running fine and also application which i installed...please help me out in this so ill be thankful