Showing results for 
Search instead for 
Did you mean: 

SGLX 11.19 and HPSMH

Riad Gaffar
Occasional Visitor

SGLX 11.19 and HPSMH


I have upgraded to SGLX 11.19 from 11.18 went through all document and made sure I have installed everything correctly. I have a single cluster that has only two nodes. Every thing is up and running except for the "Seviceguard" Link in the HPSMH. Once clicked it says "Service is Temporarily unavailable..try back later". Also in the main page I don't have any components like I used to have in 11.18. It seems like I am missing a module or something but can't figure out. Does any one have any idea? Any input is much appreciated.


Riad Gaffar
Occasional Visitor

Re: SGLX 11.19 and HPSMH

I did some search and found this thread:

I am getting similar error message in /var/spool/opt/hp/hpsmh/logs/error_log file.

[Wed Sep 16 10:22:45 2009] [error] [client] File does not exist: /opt/hp/hpsmh/data/htdocs/sgmgr, referer: https://localhost:2381/sgmgr/main/

I've got the following java version
java version "1.6.0_10"
Java(TM) SE Runtime Environment (build 1.6.0_10-b33)
Java HotSpot(TM) Server VM (build 11.0-b15, mixed mode)

It seems like I need sun java sdk?
Steven E. Protter
Exalted Contributor

Re: SGLX 11.19 and HPSMH

Shalom Riad,

Sounds to me like updating Java is a good idea. I can't see needing the SDK, but you may have a patching issue.

I don't see the need for SGLX to work with HPSMH. It is not required for proper SG operations.

Steven E Protter
Owner of ISN Corporation
Riad Gaffar
Occasional Visitor

Re: SGLX 11.19 and HPSMH

After getting the java-devel and upto-date jdk package from RHN I was able to bring up the serviceguard in the HPSMH. I also installed the patch (SGLX_00264) for it. Now my new issues is the license. Apparently this new version requires a permanent license from