HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

SGLX Lock Lun problem!

 
C'est Pierre
Advisor

SGLX Lock Lun problem!

Alright, so I have this going on:

# cmcheckconf -v -C /opt/cmcluster/conf/clust1.config

Checking cluster file: /opt/cmcluster/conf/clust1.config
Checking nodes ... Done
Checking existing configuration ... Done
Warning: Unable to get configuration for cluster cluster1.
Gathering configuration information ... Done
Gathering configuration information ..
Gathering storage information ..
Found 1 devices on node lxoradb01
Found 1 devices on node lxoradb02
Analysis of 2 devices should take approximately 1 seconds
0%----10%----20%----30%----40%----50%----60%----70%----80%----90%----100%
.....
Gathering Network Configuration ........ Done
Checking for inconsistencies .. Done
Error: /dev/dm-3p1 is not a valid device. Validation failed.
Error: Invalid data for cluster lock LUN configuration
Maximum configured packages parameter is 1.
Configuring 0 package(s).
1 package(s) can be added to this cluster.
200 access policies can be added to this cluster.
cmcheckconf : Unable to verify cluster file: /opt/cmcluster/conf/clust1.config.


I found it weird, since I created the lock lun partition in the way the manual described, so I've gone again through the process, just to make sure:



# fdisk /dev/dm-3

The number of cylinders for this disk is set to 51200.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
(e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): t
Partition number (1-4): 1
Hex code (type L to list codes): 83

Command (m for help): p

Disk /dev/dm-3: 53.6 GB, 53687091200 bytes
64 heads, 32 sectors/track, 51200 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes

Device Boot Start End Blocks Id System
/dev/dm-3p1 1 1 1008 83 Linux
/dev/dm-3p2 2 51200 52427776 8e Linux LVM

Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.

WARNING: Re-reading the partition table failed with error 22: Invalid argument.
The kernel still uses the old table.
The new table will be used at the next reboot.
Syncing disks.


However, it still gave me the same output when I ran the cmcheckconf. This seems to be another problem which I am not being able to spot nor figure out. Anyone able to help me? also, there's other errors aside from the lock lun partition that I have no idea about, like "cmcheckconf : Unable to verify cluster file: /opt/cmcluster/conf/clust1.config.".


Thank you very much!
4 REPLIES
mmfpbw
Advisor

Re: SGLX Lock Lun problem!

Bonjour,

for some reason the lock lun disk should be in the form /dev/sdXX or /dev/ccissXX. I don't know why but it is written in many threads in this forum.

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1033536

What kind of disk are you using? The form /dev/dm?? seems strange to me ?

If you have to use this dm device you should map it with udev.

HTH & regards
Matthias

C'est Pierre
Advisor

Re: SGLX Lock Lun problem!

Hello!

dm-3 is the 3rd device, of the "Device Mapper", the kernel sub-system used and supported by HP for multipathing. It is also the device which gives us the multipathing of the fiber cards. If mc serviceguard only supports /dev/sd*, this is hilarious given what I just said.

How will I guarantee fibercard failover/load balancing with a /dev/sd* ?

Anyways, I tried making /dev/sdc, /dev/sdc1 and so on, with mknod, but serviceguard still said it wasn't valid.
Serviceguard for Linux
Honored Contributor

Re: SGLX Lock Lun problem!

DM is not supported with Serviceguard. You must use QLogic multipathing. LockLUN uses commands to double check that the LUN is really the same when being accessed from both nodes. SM does not pass those commands.
C'est Pierre
Advisor

Re: SGLX Lock Lun problem!

Hello,

Where can I find documentation for that QLogic Multipath and all the tools/drivers needed?

Thank you!