HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

Service Guard Problem

 
Roei Goldenberg
Occasional Visitor

Service Guard Problem

Hello Everyone

I have a problem when I'm tring to run cmquerycl on a to new nodes runnig Red Hat ES 4 on VMWare server.
The messeage I get is:
Looking for other clusters ... Done
Node lnx3 is refusing Serviceguard communication.
Please make sure that the proper security access is configured on node
lnx3 through either file-based access (pre-A.11.16 version) or role-based
access (version A.11.16 or higher) and/or that the host name lookup
on node lnx3 resolves the IP address correctly.
Failed to gather configuration information.

Nslookup look fine, and ping is flowing well.

I'm attaching my host file:
# Do not remove the following line, or various programs
# that require network functionality will fail.
#### LoopBack Adresses
# IPv4 Lo
127.0.0.1 localhost.localdomain localhost

#### Cluster Member Nodes
# First Cluster Member Node (This Node)
14.0.0.1 rhlnx3.test rhlnx3
# Second Cluster Member Node
14.0.0.2 rhlnx4.test rhlnx4

#### Heartbeat Connections
# First Heartbeat Connection (This node)
13.0.0.1 lnx3
# Second Heartbeat Connection
13.0.0.2 lnx4

#### Packeges IP's

My cmclnodelist looks like that:
############################################################
# Do Not Edit This File
# This is only a temporary file to bootstrap an unconfigured
# node with Serviceguard version A.11.16
# Once a cluster is created, Serviceguard will not consult
# this file, and it's to be removed then.
############################################################
lnx3 root # Cluster1, Node 1
lnx4 root # Cluster1, Node 2

Also the messages log show nothing.

Pleas help me cause I don't have any idea.

Thanks
6 REPLIES
Suraj K Sankari
Honored Contributor

Re: Service Guard Problem

Hi,

Please make sure about below things.
1.nslookup, linkloop all should be happned between all NIC Cards.
2.login to other node with out passwd like remsh hostname.
3.service guard should be installed into both the noeds with licence.

then try with
clquerycl -C clustername -n node1 -n node2

Suraj
likid0
Honored Contributor

Re: Service Guard Problem

I don't now in linux, but in HP-UX you normally need to have your identd working:

check it out in /etc/inetd.conf

auth stream tcp6 wait bin /usr/lbin/identd identd

and also:

hacl-cfg dgram udp wait root /usr/lbin/cmclconfd cmclconfd -p
hacl-cfg stream tcp nowait root /usr/lbin/cmclconfd cmclconfd -c

if you change the file, then reload the info

inetd -c
Windows?, no thanks
John Bigg
Esteemed Contributor

Re: Service Guard Problem

I am not sure that this is the problem, but you certainly have a misconfiguration. As documented in the manual you MUST have the hostname as an alias for ALL ip addresses on the system. i.e. I would expect you to have:

# Do not remove the following line, or various programs
# that require network functionality will fail.
#### LoopBack Adresses
# IPv4 Lo
127.0.0.1 localhost.localdomain localhost

#### Cluster Member Nodes
# First Cluster Member Node (This Node)
14.0.0.1 rhlnx3.test rhlnx3 lnx3
# Second Cluster Member Node
14.0.0.2 rhlnx4.test rhlnx4 lnx4

#### Heartbeat Connections
# First Heartbeat Connection (This node)
13.0.0.1 lnx3
# Second Heartbeat Connection
13.0.0.2 lnx4

This assumes that the hostnames of the two systems are lnx3 and lnx4.
Serviceguard for Linux
Honored Contributor

Re: Service Guard Problem

The comment on identd is a good one.

Some of my "standard response" is here:

http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1229623630425+28353475&threadId=1278344

This should be a good start.
Roei Goldenberg
Occasional Visitor

Re: Service Guard Problem

hello

First of all, thanks for trying helping me.

secomd I will reply each of you.
Suraj: service guard is install on both nodes and i had a problem to rlogin, but i fixed it.
I don't sure I understood your first remark about the nslookup.
can you give an exsample?

Orange_adm: the files you mentioned looks like they should.

John Bigg: I change /etc/hosts like you said and the only change is that i get "Permission denied to 13.0.0.2
Warning: Unable to determine local domain name for rhlnx3" before the message i got before.

Serviceguard for Linux: I made sure that identd works fine and I even tried to disable identd before I possed this thread.


If all of you guy have more idea I will like to hear them

Thanks
Roei Goldenberg
Occasional Visitor

Re: Service Guard Problem

Problem solved.

It was a problem with the hosts file whitch I steal don't understand, but I chaned the alias to rhlnx instead of lnx and it work.

I also installed some patches.

Thank you all especially to Suraj K Sankari and John Bigg . I there is a way I can change your grade pleas tell me cause you gave a good tip.