cancel
Showing results for 
Search instead for 
Did you mean: 

Service guard lock lun issue

Liz_30
Occasional Visitor

Service guard lock lun issue

Im currently building this in vmware as Im doing a proof of documentation and dont have enough physical hardware to hand to do it the proper way.

hosta, hostb
both have 128mb memory (yes sorry)
8gb /dev/sda

duel access too
1gb /dev/sdb
8db /dev/sdc

I created a cluster, it forms, works fine with a quorum server running on the host. (All 3 running redhat 3 ES)
Moment I try to do locklun so remove the dependancy on the host, it fails, it tells me

/dev/sdb1 is not a valid device. Validation Failed.

Having read various documentation
I tried setting /etc/sysconfig/rawdevices
I tried with a partition type of 83 and 8e
I tried formatted partitions and unformated.

Cluster config

CLUSTER_NAME cluster1
NODE_NAME hosta
NETWORK_INTERFACE eth0
HEARTBEAT_IP 192.168.100.128
CLUSTER_LOCK_LUN /dev/sdb1
NODE_NAME hostb
NETWORK_INTERFACE eth0
HEARTBEAT_IP 192.168.100.129
CLUSTER_LOCK_LUN /dev/sdb1
HEARTBEAT_INTERVAL 1000000
NODE_TIMEOUT 2000000
AUTO_START_TIMEOUT 600000000
NETWORK_POLLING_INTERVAL 2000000
MAX_CONFIGURED_PACKAGES 5


:(

Why does it hate me so?
5 REPLIES
jfcaby
Occasional Advisor

Re: Service guard lock lun issue

Hi

I've exactly the same pb in VMware Workstation v4.0.5 with :
- Red Hat Enterprise Linux 3 AS x86 Update 5
- HP Serviceguard A.11.16

Error message appears during cmcheckconf script :
# cmcheckconf -v -C $SGCONF/isengard.config

Checking cluster file: /usr/local/cmcluster/conf/isengard.config
Checking nodes ... Done
Checking existing configuration ... Done
Warning: Unable to get configuration for cluster isengard.
Gathering configuration information ... Done
Gathering configuration information ..
Gathering storage information ..
Found 1 devices on node saroumane
Found 1 devices on node sauron
Analysis of 2 devices should take approximately 1 seconds
0%----10%----20%----30%----40%----50%----60%----70%----80%----90%----100%
.....
Gathering Network Configuration ........ Done
Checking for inconsistencies .. Done
Error: /dev/sdc1 is not a valid device. Validation failed.
Error: Invalid data for cluster lock LUN configuration
Maximum configured packages parameter is 5.
Configuring 0 package(s).
5 package(s) can be added to this cluster.
200 access policies can be added to this cluster.
cmcheckconf : Unable to verify cluster file: /usr/local/cmcluster/conf/isengard.config.

For the moment i don't found any solution to correct it...
Steven E. Protter
Exalted Contributor

Re: Service guard lock lun issue

You need to use lvm (lvcreate et all) to set up a volume group and a logical volume for Serviceguard to use.

Once you do that, if it runs at all on a 128 MB machine, make sure all networks have ping network connectivity and everything should be fine.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
jfcaby
Occasional Advisor

Re: Service guard lock lun issue

LVM volumes are used for Serviceguard data disks only.

Cluster Lock LUN aren't created with LVM.

The lock LUN requires a partition of 100K defined with the fdisk command as type Linux (83).
Serviceguard for Linux
Honored Contributor

Re: Service guard lock lun issue

I have tried this as well. I have not yet figured out a way to get locklun to work under VMWare. I tried all sorts of shared disk setups in vmware.

For all monitoring this, this is not supported, but like Liz I was trying to do this for demos, etc.

Liz - let me assure you that LockLUN does work.
Liz_30
Occasional Visitor

Re: Service guard lock lun issue

Well if you guys cant get it to work, us mere mortals arent likely. This is a relief. However, does make it annoying for the purpose its being done.

However, thanks for all your help!