Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

ServiceGuard in Linux logs cmclconfd running with weak security (identd disabled)

 
SOLVED
Go to solution
Rob_Taylor
Advisor

ServiceGuard in Linux logs cmclconfd running with weak security (identd disabled)

Hi,

I'm getting these entries in the /var/log/messages logs on a two nodes SUSE Linux cluster. The cluster works fine. These messages are just a nuisance. Any thoughts folks?
Mar 9 09:09:37 utlmad0p0118 cmclconfd[11856]: cmclconfd running with weak security (identd disabled)
Mar 9 09:09:39 utlmad0p0118 cmclconfd[11867]: cmclconfd running with weak security (identd disabled)
Mar 9 09:11:47 utlmad0p0118 cmclconfd[12196]: cmclconfd running with weak security (identd disabled)
Mar 9 09:14:06 utlmad0p0118 cmclconfd[12521]: cmclconfd running with weak security (identd disabled)
Mar 9 09:14:18 utlmad0p0118 cmclconfd[12544]: cmclconfd running with weak security (identd disabled)
Mar 9 09:14:19 utlmad0p0118 cmclconfd[12545]: cmclconfd running with weak security (identd disabled)
4 REPLIES
smatador
Honored Contributor
Solution

Re: ServiceGuard in Linux logs cmclconfd running with weak security (identd disabled)

Hi,

Maybe you have to install some patches.

For example, if you are on SLES9 and Serviceguard A.11.16.12 you have a patches which resolve this issue SGLX_00124.
Check for patches on your release.

Hope it helps
John Bigg
Esteemed Contributor

Re: ServiceGuard in Linux logs cmclconfd running with weak security (identd disabled)

These messages are caused by running with the -i option on the tcp cmclconfd daemon which disabled use of identd. This is "weak security" and is the reason for these messages.

It is recommended to have the identd service enabled and run without the -i option which will prevent these messages and give you a more secure environment.

However, due to the number of messages seen, a fix was introduced so this message would only be logged once per cluster start. Therefore if you really want to run with weak security you should be able to reduce the frequency of the messages by loading the latest patch for your release.
Rob_Taylor
Advisor

Re: ServiceGuard in Linux logs cmclconfd running with weak security (identd disabled)

Thanks I've installed the patch SGLX_00124 and you're both correct. It fixes the error messages to only run when the cluster is started up. Thanks for the help
Rob_Taylor
Advisor

Re: ServiceGuard in Linux logs cmclconfd running with weak security (identd disabled)

see above