HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

Serviceguard Script failed with no restart

 
KOUYATE MAURY
Frequent Advisor

Serviceguard Script failed with no restart

Hi,My package with the default config work perfect. But when i customize and run it, it gives me this error:oraserv1:~ # cmrunpkg orapkgcmrunpkg : Script failed with no restart: orapkg should not be restarted.Check the syslog on node oraserv1 and pkg log files for more detailed information.this is the out put of the log:###### Node "oraserv1": Starting package at Fri Jan 6 04:56:29 PST 2006 ######/opt/cmcluster/conf/orapkg/orapkg.sh: line 1: wc: command not foundERROR: Function get_md; Failed to RUN vgcfgrestore###### Node "oraserv1": Package start failed at Fri Jan 6 04:56:29 PST 2006 ######What can be missing?NB: i have attached my control script file.Kouyate
5 REPLIES

Re: Serviceguard Script failed with no restart

If you look at your script, you see that "ERROR: Function get_md; Failed to RUN vgcfgrestore" comes from test_return case 27.

Looking at the "#-------------------MAINLINE Control Script Code Starts Here-----------------" section, you can see that we first call some startup checks, then we do:
verify_physical_data_replication $1
Does nothing because DATA_REP="none"
activate_md
Does nothing because there are no md devices specified
activate_volume_group
I suspect that here's our problem. From the script:
# First lets do a sanity check to see if the vg really has
# a configuration backup. If not then we report this and
# exit. It is a prereq that a vgcfgbackup be done after
# the vg configuration is built and before sg is started.
vgcfgrestore -n ${vgname} -ll -t >/dev/null 2>&1
test_return 27

This vgcfgrestore command fails for some reason and the test_return 27 spits out the error. Try running the vgcfgrestore command manually without redirecting the output to /dev/null and see what error you get. Perhaps a vgcfgbackup just needs to be done.
Sivakumar TS
Honored Contributor

Re: Serviceguard Script failed with no restart


Hi,

Are you able to activate the VG from outside the cluster.

Try this,

#vgchange -c n

#vgchange -a e

you can try to mount the lvols and check.

you can run a #vgcfgbackup also if needed.

After confirming this,

you can

unmount the lvols,

#vgchange -a n

#vgchange -c y

and try to start the orapkg.

Observe the syslog.log as well as the *.log of the package.

With Regards,

Siva.
Nothing is Impossible !
KOUYATE MAURY
Frequent Advisor

Re: Serviceguard Script failed with no restart

Hi,find attached my error messages.i don't know much about this aspect i need a help to get this scrip running.kouyate
KOUYATE MAURY
Frequent Advisor

Re: Serviceguard Script failed with no restart

Hi SivaI have the same error as follow:This is the orapkg.sh.log out put.###### Node "oraserv1": Starting package at Fri Jan 6 07:54:25 PST 2006 ######/opt/cmcluster/conf/orapkg/orapkg.sh: line 1: wc: command not foundERROR: Function get_md; Failed to RUN vgcfgrestore###### Node "oraserv1": Package start failed at Fri Jan 6 07:54:26 PST 2006 ######"orapkg.sh.log" 121L, 7020C 121,1 Botbut i can vgchange and mount without error please find attached my stepsKouyate
KOUYATE MAURY
Frequent Advisor

Re: Serviceguard Script failed with no restart

I've juste shutdown both nodes and later shutdown the storage. after 10mn, l put on the storage, when up, i put on both nodes and try to run the package. And it run without any error message.
Thanks.
Kouyate Maury