Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

Serviceguard cluster for MySQL on RHEL4

pymsh
Frequent Advisor

Serviceguard cluster for MySQL on RHEL4

Dear all
i want to make a 2-node cluster with SGLX A.11.18
and MySQL on RHEL4.
Servers=2xBL20p
Storage=MSA1000 in SAN
The package that i created with MySQL Toolkit, does not start normally, but base package on this cluster works good.
Any help will be appreciated.
7 REPLIES
Steven E. Protter
Exalted Contributor

Re: Serviceguard cluster for MySQL on RHEL4

Shalom,

No, mysql will not start normally with the standard /etc/init.d/mysqld startup script.

You will need to modify the startup script in a copy somewhat.

Please upload your configuration and error messages.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
pymsh
Frequent Advisor

Re: Serviceguard cluster for MySQL on RHEL4

Hi SEP
I have followed the "Using MySQL Toolkit in a ServiceGuard for Linux Cluster" guide and make the config and script file.
After creating and applying these files, MySQL package does not run on any nodes.
I have repeat steps 3 times, but the problem still exists.
Colin Topliss
Esteemed Contributor

Re: Serviceguard cluster for MySQL on RHEL4

Easy one to fix.

Putting the basic call to start mysql doesn't work because the environment is not correct. All you need to do is use the extract below in your SG control script, and mysql will stop/start with no problems (at least it works for me).


function customer_defined_run_cmds
{
# ADD customer defined run commands.
su - -c "/etc/init.d/mysql start"

test_return 51
}

function customer_defined_halt_cmds
{
# ADD customer defined halt commands.
su - -c "/etc/init.d/mysql stop"

test_return 52
}
pymsh
Frequent Advisor

Re: Serviceguard cluster for MySQL on RHEL4

Thank you all,
I changed content of control script to run /etc/init.d/mysqld but the problem still exists.
The error is reported as:

# cmmodpkg -e -n N1-n N2 mysql_1
Package mysql_1 is already enabled on node N1
Package mysql_1 is already enabled on node N2
cmmodpkg: Completed successfully on all packages specified

# cmrunpkg mysql_1
Running package mysql_1 on node N1
The package script for mysql_1 failed with no restart. mysql_1 should not be restarted
Unable to run package mysql_1 on node N1
Check the syslog and pkg log files for more detailed information
cmrunpkg: Unable to start some package or package instances

As i said before, i followed T2377-90001 MySQL Toolkit Guide for configuration.
Any suggestion??
Colin Topliss
Esteemed Contributor

Re: Serviceguard cluster for MySQL on RHEL4

What's in the package log file?
pymsh
Frequent Advisor

Re: Serviceguard cluster for MySQL on RHEL4

Hi,
MySQL package is halted as soon as it's started!!
The MySQL log file is as followed:

###### Node "pec0360s": Starting package at Tue Jun 10 18:58:00 IRST 2008 ######
Attempting to addtag to vg vgpkg1...
addtag was successful on vg vgpkg1.
Jun 10 18:58:00 - Node "pec0360s": Activating volume group vgpkg1 .
Jun 10 18:58:00 - Node "pec0360s": Checking filesystems:
/dev/vgpkg1/MySQL_1
.
.
.
Starting MySQL: [ OK ]^M
Jun 10 18:58:02 - Node "pec0360s": Starting service mysql_monitor using
"toolkit.sh"
sh: line 0: exec: toolkit.sh: not found
###### Node "pec0360s": Package start completed at Tue Jun 10 18:58:02 IRST 2008 ######

####### Node "pec0360s": Halting package at Tue Jun 10 18:58:02 IRST 2008 #######
Jun 10 18:58:02 - Node "pec0360s": Halting service mysql_monitor
cmhaltserv: Service name mysql_monitor is not running.
. . .
Any suggestion?
Regards
melvyn burnard
Honored Contributor

Re: Serviceguard cluster for MySQL on RHEL4

Well here is a clue:
Jun 10 18:58:02 - Node "pec0360s": Starting service mysql_monitor using
"toolkit.sh"
sh: line 0: exec: toolkit.sh: not found
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Investigate this and you may find an answer
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!