Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to run cmcheckconf or cmapplyconf due to long name of Lock LUN

Unable to run cmcheckconf or cmapplyconf due to long name of Lock LUN

Hi Experts,

I am working on HP DL380 G5 server with MC serviceguard. The shared disks are configured from an EMC storage with 2 FC paths to server and so it will show 2 devices for a shared disk. I have installed multipath software to know the disk path. So that it will show the disk path as following eg.

360060480000290101545533030423146
[size=67 GB][features="0"][hwhandler="0"]
\_ round-robin 0 [prio=2][active]
\_ 1:0:0:10 sdaa 65:160 [active][ready]
\_ 0:0:0:10 sdk 8:160 [active][ready]

So the device name should be like /dev/disk/by-name/360060480000290101545533030423146 or /dev/mapper/360060480000290101545533030423146. I have configured a Lock LUN by creating a partition on this disk and the partition as /dev/disk/by-name/360060480000290101545533030423146p1 or /dev/mapper/360060480000290101545533030423146p1.

I can create the cluster ascii file by using 'cmquerycl' commmand, but failed to run 'cmcheckconf' or 'cmapplyconf' due to the long name of device file. The error show it will support max upto 39 characters for a device Lock LUN name.

Could somebody please tell me how I can increase the limit or whether I can use some other way to resolve this issue?

Please note that I am not interested to use one of the devices /dev/sdaa1 or /dev/sdk1. I need to solve this issue without loosing the advantage of 2 Fibre channel connectivity.

Thanks in advance.

Regards,
Bensi Bose TC.
bensi.bose@wipro.com
Contact # +61450013853.

4 REPLIES
Steven E. Protter
Exalted Contributor

Re: Unable to run cmcheckconf or cmapplyconf due to long name of Lock LUN

Shalom,

You can't increase the limit.

Perhaps you can get around it by writing a softlink ln -s

Also, contact HP support and get your email pulled out of this post unless you like getting spam.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Unable to run cmcheckconf or cmapplyconf due to long name of Lock LUN

Thanks for the quick reply.

But I have already tried by creating soft link as well as hard link, but it is not working with this. When I am using links, it shows invalid device file.

Thank You.
Bensi Bose TC
Matti_Kurkela
Honored Contributor

Re: Unable to run cmcheckconf or cmapplyconf due to long name of Lock LUN

The /etc/multipath.conf file has the setting "user_friendly_names". If you set it to "yes", the devices are created with names like /dev/mapper/mpath0, /dev/mapper/mpath1 and so on.

The "multipath -l" command will still show the WWIDs, if you need them. As you're using EMC storage, you could also install the free "inq" utility (available from EMC) that can display the EMC identification information for the disk devices. The EMC device numbers are much more compact than WWIDs.

Example output from a RHEL 4 machine:

mpath1 (360060480000290100288533032423739)
[size=9 GB][features="0"][hwhandler="0"]
\_ round-robin 0 [active]
\_ 2:0:0:61 sdb 8:16 [active]
\_ 3:0:0:61 sde 8:64 [active]

If the user_friendly_names option is set, the friendly names and the equivalent WWIDs are stored in a persistent fashion in file /var/lib/multipath/bindings.

MK
MK

Re: Unable to run cmcheckconf or cmapplyconf due to long name of Lock LUN

Hi Matti,

Thanks for the reply.

I have added the line "user_friendly_names yes" in /etc/multipath.conf and rebooted the machine. But still shows old device names in /dev/mapper. Please tell me whether I need to do something more to change these device names?

Your early reply will be highly appreciated.

Thanks & Rgds,
Bensi Bose TC