Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

clog_wizard exiting with error (Suse 10 SP2)

Scout (PathFinder)
Occasional Advisor

clog_wizard exiting with error (Suse 10 SP2)

Hi,
I have 4 nodes in SG cluster.
Linux 2.6.16.60-0.21-smp #1 SMP Tue May 6 12:41:02 UTC 2008 x86_64 x86_64 x86_64 GNU/Linux
# rpm -aq|grep dsau
hpdsau-1.4-1.sles10

Like in document i create vg for log consolidation tool, and with clog_wizard try to configure my cluster SAP as a log consolidation server.

But i got error from command /etc/init.d/syslog-ng restart
(see log in attachment). After that my first service syslog is down and service syslog-ng can`t start.
Where i take mistake?
1 REPLY

Re: clog_wizard exiting with error (Suse 10 SP2)

Hi

actual there are two problems we have regarding clog setup on SLES systems.
if you have apparmor installed on the system syslog-ng is protected by apparmor. you have to remove protection with the following command: "apparmor_parser --remove /etc/apparmor.d/sbin.syslog-ng"

second problem is SUSE Linux deletes additional created fifo's under /dev.
We check on every boot if the fifo is available, but we put the process in the background so we don't wait until this process has been finished. To be shure that the fifo is available at the time we try to use it, we have to add the following command to the /etc/rc.d/boot.local file: "mkfifo -m 744 /dev/log/consolidation/fifo"

In your case, you can setup clog by checking first if you have apparmor installed. If so, remove protection with apparmor_parser command. Afterwards add the mkfifo command to the boot.local file and execute the command on the prompt. Now you're ready to setup clog with clog_wizard. These problem will be fixed on a future release of hpdsau rpm packet.
cheers
Reto