Showing results for 
Search instead for 
Did you mean: 

cmapplyconf failed


cmapplyconf failed

When i am trying to execute cmapplyconf i received this error:
cmapplyconf -v -C $SGCONF/cluster.config

"Checking cluster file: /usr/local/cmcluster/conf/cluster.config

Note : a NODE_TIMEOUT value of 2000000 was found in line 117. For a

significant portion of installations, a higher setting is more appropriate.

Refer to the comments in the cluster configuration ascii file or Serviceguard

manual for more information on this parameter.

Checking nodes ... Done

Checking existing configuration ... Done

Warning: Unable to get configuration for cluster cluster1.

Gathering configuration information ... Done

Gathering configuration information ..

Gathering storage information ..

Found 1 devices on node cluster1

Found 1 devices on node cluster2

Analysis of 2 devices should take approximately 1 seconds



Gathering Network Configuration ........ Done

Error: Detected a partition of IP subnet

Partition 1

cluster1 eth0

Partition 2

cluster2 eth0

Failed to evaluate network

cmapplyconf : Unable to reconcile configuration file /usr/local/cmcluster/conf/


with discovered configuration information."
Stephen Doud
Honored Contributor

Re: cmapplyconf failed

The "detected a partition of IP subnet" message indicates there is no connectivity between eth0 on node "cluster1" and "cluster2" , or it could mean that the speed/duplex of the NICs are incompatible, or a network device between the servers does not pass layer 2 DLPI protocol messages or .....

Steven E. Protter
Exalted Contributor

Re: cmapplyconf failed


SG uses .rhosts connectivity. You have to have rlogin and such enabled in the xinetd daemon /etc/xinetd.d

By default those services are not turned on in Linux.

Also 11.16 may require different options on these utilities than prior versions. This is definitely the case with the HP-UX version.

Steven E Protter
Owner of ISN Corporation
John Bigg
Esteemed Contributor

Re: cmapplyconf failed

Just to comment on the previous message by Steven. Neither Serviceguard on HP-UX nor Linux require .rhosts to be setup or for rlogin/remsh to be enabled. The cluster will work perfectly well without these.